Bug 529486 - obex-data-server: doesn't support object exchange (Bluetooth Device)
obex-data-server: doesn't support object exchange (Bluetooth Device)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-user-share (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-17 10:37 EDT by Maximiliano Castanon
Modified: 2009-10-19 11:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-19 11:27:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maximiliano Castanon 2009-10-17 10:37:21 EDT
Description of problem:
when i try to transfer files from my phone to computer, this say "service not supported", but the obex-data-server is running...

[maximi89@gateway ~]$ hciconfig -a
hci0:	Type: USB
	BD Address: 00:11:67:CB:5D:87 ACL MTU: 1021:4 SCO MTU: 48:10
	UP RUNNING PSCAN ISCAN 
	RX bytes:8773293 acl:12264 sco:0 events:3075 errors:0
	TX bytes:45298 acl:2332 sco:0 commands:593 errors:0
	Features: 0xff 0xfe 0xff 0x7e 0x98 0x19 0x00 0x80
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF PARK 
	Link mode: SLAVE ACCEPT 
	Name: 'gateway-0'
	Class: 0x4a210c
	Service Classes: Networking, Capturing, Telephony
	Device Class: Computer, Laptop
	HCI Ver: 2.0 (0x3) HCI Rev: 0x302 LMP Ver: 2.0 (0x3) LMP Subver: 0x302
	Manufacturer: Integrated System Solution Corp. (57)



Version-Release number of selected component (if applicable):

obex-data-server 0.4.3

Linux gateway 2.6.30.8-64.fc11.i686.PAE #1 SMP Fri Sep 25 04:56:58 EDT 2009 i686 athlon i386 GNU/Linux


How reproducible:
put the bluetooth dongle on a usb, try to transfer a file from phone to computer.


Steps to Reproduce:
1.install the bluetooth dongle device
2.try to transfer a file from phone to mobile
3.
  
Actual results:
"not supported service" from a Motorola L6

Expected results:
to transfers

Additional info:

the hcidump give me this

[maximi89@gateway ~]$ sudo hcidump -V
[sudo] password for maximi89: 
HCI sniffer - Bluetooth packet analyzer ver 1.42
device: hci0 snap_len: 1028 filter: 0xffffffff
> HCI Event: Connect Request (0x04) plen 10
    bdaddr 00:1A:1B:96:93:22 class 0x522204 type ACL
< HCI Command: Accept Connection Request (0x01|0x0009) plen 7
    bdaddr 00:1A:1B:96:93:22 role 0x00
    Role: Master
> HCI Event: Command Status (0x0f) plen 4
    Accept Connection Request (0x01|0x0009) status 0x00 ncmd 1
> HCI Event: Role Change (0x12) plen 8
    status 0x00 bdaddr 00:1A:1B:96:93:22 role 0x00
    Role: Master
> HCI Event: Connect Complete (0x03) plen 11
    status 0x00 handle 1 bdaddr 00:1A:1B:96:93:22 type ACL encrypt 0x00
< HCI Command: Read Remote Supported Features (0x01|0x001b) plen 2
    handle 1
> HCI Event: Max Slots Change (0x1b) plen 3
    handle 1 slots 5
> HCI Event: Command Status (0x0f) plen 4
    Read Remote Supported Features (0x01|0x001b) status 0x00 ncmd 1
> HCI Event: Connection Packet Type Changed (0x1d) plen 5
    status 0x00 handle 1 ptype 0xff1e
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 2-DH1 2-DH3 2-DH5 3-DH1 3-DH3 3-DH5 
> HCI Event: Read Remote Supported Features (0x0b) plen 11
    status 0x00 handle 1
    Features: 0xff 0xfe 0x0d 0x00 0x08 0x08 0x00 0x00
> ACL data: handle 1 flags 0x02 dlen 12
    L2CAP(s): Connect req: psm 1 scid 0x0040
< ACL data: handle 1 flags 0x02 dlen 16
    L2CAP(s): Connect rsp: dcid 0x0040 scid 0x0040 result 1 status 0
      Connection pending - No futher information available
< ACL data: handle 1 flags 0x02 dlen 10
    L2CAP(s): Info req: type 2
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 1 packets 1
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 1 packets 1
< HCI Command: Remote Name Request (0x01|0x0019) plen 10
    bdaddr 00:1A:1B:96:93:22 mode 2 clkoffset 0x0000
> HCI Event: Command Status (0x0f) plen 4
    Remote Name Request (0x01|0x0019) status 0x00 ncmd 1
> ACL data: handle 1 flags 0x02 dlen 16
    L2CAP(s): Info rsp: type 2 result 0
      Extended feature mask 0x0000
< ACL data: handle 1 flags 0x02 dlen 16
    L2CAP(s): Connect rsp: dcid 0x0040 scid 0x0040 result 0 status 0
      Connection successful
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 1 packets 1
> HCI Event: Remote Name Req Complete (0x07) plen 255
    status 0x00 bdaddr 00:1A:1B:96:93:22 name 'Archer's L6'
> ACL data: handle 1 flags 0x02 dlen 16
    L2CAP(s): Config req: dcid 0x0040 flags 0x00 clen 4
      MTU 1024 
< ACL data: handle 1 flags 0x02 dlen 18
    L2CAP(s): Config rsp: scid 0x0040 flags 0x00 result 0 clen 4
      MTU 1024 
< ACL data: handle 1 flags 0x02 dlen 12
    L2CAP(s): Config req: dcid 0x0040 flags 0x00 clen 0
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 1 packets 1
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 1 packets 1
> ACL data: handle 1 flags 0x02 dlen 14
    L2CAP(s): Config rsp: scid 0x0040 flags 0x00 result 0 clen 0
      Success
> ACL data: handle 1 flags 0x02 dlen 34
    L2CAP(d): cid 0x0040 len 30 [psm 1]
        SDP SSA Req: tid 0x1 len 0x19
          pat uuid-16 0x1105 (OBEXObjPush)
          max 128
          aid(s) 0x0000 (SrvRecHndl) 0x0001 (SrvClassIDList) 0x0002 (SrvRecState) 0x0006 (LangBaseAttrIDList) 0x0009 (BTProfileDescList)
          cont 00
< ACL data: handle 1 flags 0x02 dlen 14
    L2CAP(d): cid 0x0040 len 10 [psm 1]
        SDP SSA Rsp: tid 0x1 len 0x5
          count 2
          cont 00
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 1 packets 1
> ACL data: handle 1 flags 0x02 dlen 12
    L2CAP(s): Disconn req: dcid 0x0040 scid 0x0040
< ACL data: handle 1 flags 0x02 dlen 12
    L2CAP(s): Disconn rsp: dcid 0x0040 scid 0x0040
> HCI Event: Number of Completed Packets (0x13) plen 5
    handle 1 packets 1
> HCI Event: Disconn Complete (0x05) plen 4
    status 0x00 handle 1 reason 0x13
    Reason: Remote User Terminated Connection
Comment 1 Maximiliano Castanon 2009-10-17 23:09:34 EDT
[maximi89@gateway ~]$ python /usr/share/doc/obex-data-server-0.4.3/ods-server-test.py --ask-to-accept opp /tmp/


[maximi89@gateway ~]$ obex-data-server --no-daemon
** Message: obex-data-server 0.4.3
** Message: Using Session bus
** Message: server socket created
** Message: Server created by: :1.432

** (obex-data-server:27165): WARNING **: Server path: /tmp/
** Message: Client connecting

** (obex-data-server:27165): WARNING **: Session path: /tmp/
** Message: Bluetooth address: 00:1A:1B:96:93:22
** Message: Creating server session
** Message: io callback
** Message: event: 1
** Message: event: 2
** Message: CMD_CONNECT requested
** Message: Version: 0x10. Flags: 0x00  OBEX packet length: 5126

** Message: Resizing stream chunks to 4926

** Message: event: 3
** Message: io callback
** Message: event: 1
** Message: event: 11
** Message: CMD_PUT requested at REQCHECK
** Message: header: 66
** Message: HDR_TYPE: video/3gpp
** Message: header: 1
** Message: HDR_NAME: 03-10-09_1237.3gp
** Message: header: 195
** Message: HDR_LENGTH: 254860
** Message: path: /tmp/
** Message: ret=0
** Message: TransferStarted emitted at obex_request_put
** Message: suspending request
** Message: LOCK ods_server_session_reject
** Message: UNLOCK ods_server_session_reject
** Message: suspend result: -1
** Message: event: 4

** (obex-data-server:27165): WARNING **: EV_LINKERR
** Message: io callback
** Message: server session closed
** Message: closing connection

** (obex-data-server:27165): WARNING **: DBUS NAME REMOVED: :1.432

** (obex-data-server:27165): WARNING **: Finalizing server
** Message: server stopped
** Message: SDP service unregistered
** Message: Disposing Server
** Message: Server disposed at once
** Message: server closed
** Message: Removing listened DBUS name :1.432 (object: /org/openobex/server0)
** Message: Removed from listened DBUS names list

obex-data-server don't start the server like it would do...
but if i start a test server:

 python /usr/share/doc/obex-data-server-0.4.3/ods-server-test.py --ask-to-accept opp /tmp/

 work very well sharing files... but if i don't start it, OBS transfers files doesn't works...


[maximi89@gateway ~]$ gconftool-2 --recursive-list /desktop/gnome/file_sharing
 bluetooth_obexpush_enabled = true
 bluetooth_accept_files = bonded_and_trusted
 bluetooth_enabled = false
 bluetooth_notify = true
 enabled = false
 require_password = never
 bluetooth_require_pairing = true
 bluetooth_allow_write = false
Comment 2 Maximiliano Castanon 2009-10-18 11:38:31 EDT
ods-test-server give to obex-data-server the funcionality to receive files from my phone, but obex-data-server doesn't support the funcionality, i have given the permission

[maximi89@gateway ~]$ gconftool-2 --recursive-list /desktop/gnome/file_sharing
 bluetooth_obexpush_enabled = true

the same happens me on GNU/Linux Debian
http://bugs.muiline.com/view.php?id=162
Comment 3 Bastien Nocera 2009-10-18 22:20:09 EDT
obex-data-server doesn't do anything on its own.

Did you follow the instructions at:
http://fedoraproject.org/wiki/Documentation/Bluetooth#Receiving.2FSharing_files_via_ObexFTP_and_ObexPush ?

Is gnome-user-share installed and running?
Comment 4 Maximiliano Castanon 2009-10-19 11:04:15 EDT
yes, gnome-user-share is installed and runnuing

[maximi89@gateway ~]$ ps -e |grep gnome-user-shar
27020 ?        00:00:00 gnome-user-shar

the problem is the obex-data-server doesn't support object exchange...

the phone give me an error, "service not supported"
Comment 5 Bastien Nocera 2009-10-19 11:27:15 EDT
You already filed this bogus bug upstream[1], closing this one.

[1]: https://bugzilla.gnome.org/show_bug.cgi?id=584582

Note You need to log in before you can comment on or make changes to this bug.