Bug 52954 - ddd no longer handles TAB characters in source display
Summary: ddd no longer handles TAB characters in source display
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ddd
Version: 7.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-31 13:00 UTC by greg hosler
Modified: 2008-05-01 15:38 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-09-05 12:43:15 UTC


Attachments (Terms of Use)

Description greg hosler 2001-08-31 13:00:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-2smp i686; Nav)

Description of problem:
id you have source code with tabs in it (who doesn't?)
and you click on a variable in a line that has tabs
in it, the line is repainted wrongly. the variable highlighted is NOT the
variable that you clicked on. This bug has to do w/ handling of TAB
characters.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create a small 4 line hello_world source file:
main()
{
    	printf("hello world\n");
}

Note the <TAB> before the printf
2.cc -g -o foo foo.c
3.ddd foo
4. click on the printf, then click on hello, then click on world.
	

Actual Results:  line should not be repainted wrongly

Expected Results:  line should not look like it is being repainted. the
text
should not "move" out from under you.

Additional info:

This has worked in every (I thinko) beta so far. I am pretty sure it
worked in rc1.

I am marking tjis as high, not because of loss of data, but because it
renders ddd quite difficult to use (also, by checking the changelog between
rc1, and rc2, you will probably find out the problem and it probably is a
simple fix - this has almost always worked before.)

Comment 1 greg hosler 2001-09-05 12:11:43 UTC
Bug retested against RC2.

Bug still reproduceable. 100%


Comment 2 Ngo Than 2002-01-17 00:01:50 UTC
rebuild against openmotif, which will be in rawhide.


Note You need to log in before you can comment on or make changes to this bug.