Bug 52958 - gcc crashed while compile Sun's hotspot-1.3.1
Summary: gcc crashed while compile Sun's hotspot-1.3.1
Status: CLOSED DUPLICATE of bug 52905
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-31 15:22 UTC by Sean Zhong
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-31 15:25:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output log of the building process (14.24 KB, text/plain)
2001-08-31 15:25 UTC, Sean Zhong
no flags Details

Description Sean Zhong 2001-08-31 15:22:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
gcc crashed while compile file 'bytes_linux_i486.inline.hpp'
in SUN's hotspot1.3.1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download unpack; Sun's j2sdk-1.3.1-src
2.cd hotspot1.3.1/build/linux
3.gmake product
4.
	

Actual Results:  ...
Compiling /home/seanz/hotspot1.3.1/build/linux/../../src/share/vm/memory/ca
rtable.cpp
Compiling /home/seanz/hotspot1.3.1/build/linux/../../src/share/vm/runtime/c
lassFileParser.cpp
In file included 
from /home/seanz/hotspot1.3.1/src/share/vm/oops/constantPoolOop.hpp:60,
                 
from /home/seanz/hotspot1.3.1/build/linux/../../src/share/vm/runtime/classF
ileParser.cpp:84:
/home/seanz/hotspot1.3.1/src/os_cpu/linux_i486/vm/bytes_linux_i486.inline.h
pp:52: Internal error: 
Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
gmake[2]: *** [classFileParser.o] Error 1
gmake[2]: Leaving directory 
`/home/seanz/hotspot1.3.1/build/linux/linux_i486_compiler2/product'
gmake[1]: *** [the_vm] Error 2
gmake[1]: Leaving directory 
`/home/seanz/hotspot1.3.1/build/linux/linux_i486_compiler2/product'
gmake: *** [product] Error 2


Additional info:

Comment 1 Sean Zhong 2001-08-31 15:25:12 UTC
Created attachment 30334 [details]
output log of the building process

Comment 2 Jakub Jelinek 2001-08-31 18:19:53 UTC

*** This bug has been marked as a duplicate of 52905 ***


Note You need to log in before you can comment on or make changes to this bug.