Bug 529637 - [gu_IN]fontconfig suggests "Lohit Gujarati" when requesting a font that supports '1', but Lohit Gujarati doesn't have that glyph
Summary: [gu_IN]fontconfig suggests "Lohit Gujarati" when requesting a font that suppo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-gujarati-fonts
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 529521 (view as bug list)
Depends On:
Blocks: 530943
TreeView+ depends on / blocked
 
Reported: 2009-10-19 09:20 UTC by Caolan McNamara
Modified: 2009-12-01 04:32 UTC (History)
6 users (show)

Fixed In Version: 2.4.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 530943 (view as bug list)
Environment:
Last Closed: 2009-12-01 04:32:24 UTC
Type: ---


Attachments (Terms of Use)
demo (1.04 KB, text/x-c)
2009-10-19 09:21 UTC, Caolan McNamara
no flags Details

Description Caolan McNamara 2009-10-19 09:20:54 UTC
Description of problem:
Requesting a font in gu_IN locale which can render '1' returns Lohit Gujarati which doesn't have a glyph for 1

Version-Release number of selected component (if applicable):
fontconfig-2.7.3-1.fc12

How reproducible:
100%

Steps to Reproduce:
1. gcc `pkg-config --cflags --libs fontconfig` fontconfigdemo.c
2. ./a.out
  
Actual results:
"Lohit Gujarati"

Expected results:
A font which contains a glyph for 1

Comment 1 Caolan McNamara 2009-10-19 09:21:47 UTC
Created attachment 365219 [details]
demo

Am I missing something obvious here ?

Comment 2 Behdad Esfahbod 2009-10-23 20:22:28 UTC
$ fc-match ':lang=gu-IN' --verbose
Pattern has 30 elts (size 32)
	family: "Lohit Gujarati"(s)
	familylang: "en"(s)
	style: "Regular"(s)
	stylelang: "en"(s)
	fullname: "Lohit Gujarati"(s)
	fullnamelang: "en"(s)
	slant: 0(i)(s)
	weight: 80(i)(s)
	width: 100(i)(s)
	size: 12(f)(s)
	pixelsize: 12.5(f)(s)
	foundry: "unknown"(s)
	hintstyle: 3(i)(s)
	hinting: FcTrue(s)
	verticallayout: FcFalse(s)
	autohint: FcFalse(s)
	globaladvance: FcTrue(s)
	file: "/usr/share/fonts/lohit/lohit_gu.ttf"(s)
	index: 0(i)(s)
	outline: FcTrue(s)
	scalable: FcTrue(s)
	dpi: 75(f)(s)
	scale: 1(f)(s)
	charset: 
	0000: 00000000 ffffffff f8000001 78000001 00000000 00000004 00000000 00800000
	0009: 00000000 00000000 00000000 00000030 00000000 00000000 00000000 00000000
	000a: 00000000 00000000 00000000 00000000 fffbbfee f3edfdff 00013bbf 0002ffcf
	0020: 33183000 00000040 00000000 00000000 00000000 00000000 00000000 00000000
	0022: 00040000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
	0025: 00000000 00000000 00000000 00000000 00000000 00000000 00001000 00000000
(s)
	lang: gu(s)
	fontversion: 157286(i)(s)
	capability: "otlayout:gujr"(s)
	fontformat: "TrueType"(s)
	embeddedbitmap: FcTrue(s)
	decorative: FcFalse(s)

The charset element suggests that fontconfig thinks the font covers ASCII digits (those are one bit per char).  So the problem is not with your code.

Well, checking the font in fontforge, it does have glyphs for ASCII digits.  Something's wrong with the cmap.  Normally you don't see them mapped, but select "Compact" encoding in fontforge and you see that glyphs ids 125 on are the digits.

Comment 3 Pravin Satpute 2009-10-27 04:33:10 UTC
yep, numerals have a wrong encoding values thats why this bug is coming
i will fix this in next version of lohit-gujarati-fonts, 

thanks Caolan for notifying this

Comment 4 Pravin Satpute 2009-10-28 12:16:13 UTC
fixed problem
built lohit-gujarati-fonts-2.4.4-1 for F12 as well devel

Comment 5 Caolan McNamara 2009-10-30 10:39:46 UTC
*** Bug 529521 has been marked as a duplicate of this bug. ***

Comment 6 Bug Zapper 2009-11-16 13:50:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Fedora Update System 2009-11-30 09:21:52 UTC
lohit-gujarati-fonts-2.4.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/lohit-gujarati-fonts-2.4.4-1.fc12

Comment 8 Fedora Update System 2009-12-01 04:32:19 UTC
lohit-gujarati-fonts-2.4.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.