Bug 52975 - Dirs in /usr/share/apps/kscd/cddb/* have wrong permission
Summary: Dirs in /usr/share/apps/kscd/cddb/* have wrong permission
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdemultimedia   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-31 20:08 UTC by Karsten Weiss
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-31 20:11:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karsten Weiss 2001-08-31 20:08:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
kscd can't store cddb information in the /usr/share/apps/kscd/cddb/*
directories because a normal user can't write to directories with
755 root.root permissions.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Enter cddb data into kscd for a CD
2.Try to save it.
3.
	

Actual Results:  Saving fails.

Additional info:

Comment 1 Bernhard Rosenkraenzer 2001-08-31 20:11:46 UTC
No, this is intentional. World-writable directories are a major security 
problem.

If you trust all your local users, change the permissions on the directory 
yourself.


Note You need to log in before you can comment on or make changes to this bug.