Bug 529775 - Mount uses "nfsvers=3" even when "-t nfs4" is specified
Mount uses "nfsvers=3" even when "-t nfs4" is specified
Status: CLOSED DUPLICATE of bug 529407
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-19 18:20 EDT by Andrew McNabb
Modified: 2009-10-20 08:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-20 08:23:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew McNabb 2009-10-19 18:20:08 EDT
Description of problem:

In Rawhide (with nfs-utils-1.2.0-16.fc12.x86_64), I tried running:

mount -t nfs4 10.0.0.10:/ /aml

which threw the error:

mount.nfs4: an incorrect mount option was specified

Apparently NFSv3 works: mount -t nfs 10.0.0.10:/aml /aml

I am using the same server from up-to-date Fedora 11 clients (with nfs-utils-1.2.0-5.fc11.x86_64) where mount.nfs4 works without any problems.

I tried again after running `rpcdebug -m nfs -s mount` and then got the errors:

Oct 19 16:14:55 localhost kernel: NFS: nfs mount opts='nfsvers=3,addr=10.0.0.10,clientaddr=10.0.0.218'
Oct 19 16:14:55 localhost kernel: NFS:   parsing nfs mount option 'nfsvers=3'
Oct 19 16:14:55 localhost kernel: NFS:   parsing nfs mount option 'addr=10.0.0.10'
Oct 19 16:14:55 localhost kernel: NFS: parsing IPv4 address 10.0.0.10
Oct 19 16:14:55 localhost kernel: NFS:   parsing nfs mount option 'clientaddr=10.0.0.218'
Oct 19 16:14:55 localhost kernel: NFS4: Illegal mount version

Apparently something is specifying nfsvers=3 even though I gave it "-t nfsv4".
Comment 1 Steve Dickson 2009-10-20 08:23:31 EDT

*** This bug has been marked as a duplicate of bug 529407 ***

Note You need to log in before you can comment on or make changes to this bug.