Bug 52981 - installation of new kernel clobbered "default saved" in grub.conf
installation of new kernel clobbered "default saved" in grub.conf
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: mkinitrd (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-31 17:39 EDT by Jay Berkenbilt
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 10:41:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2001-08-31 17:39:54 EDT
Description of Problem:

installation of new kernel didn't quite get my grub.conf right. 
Specifically, it changed default saved to default 0.

Version-Release number of selected component (if applicable):

installing kernel 2.4.7-6

How Reproducible:

presumably always....

Steps to Reproduce:
1. edit /boot/grub/grub.conf to change default 0 to default saved and to  
  add savedefault at the end of first item.
2. install new kernel

Actual Results:

/boot/grub/grub.conf has an entry for the new kernel, but default is now 0
instead of saved.  savedefault was preserved, however, even though it is
now useless.

Expected Results:

A new entry for the new kernel should have been added, but it should not
have messed around with default.  Who's to say my default was even going to
be Linux?  (Mine would always be, but some of my best friends are Windows
users.)

Additional Information:
	
My grub.conf before:

--------
default saved
timeout 10
splashimage (hd0,6)/boot/grub/splash.xpm.gz
title roswell (2.4.7-2)
	root (hd0,6)
	kernel /boot/vmlinuz-2.4.7-2 ro root=/dev/hda7
	initrd /boot/initrd-2.4.7-2.img
	savedefault
title seawolf (2.4.3-12)
	root (hd0,1)
	kernel /boot/vmlinuz-2.4.3-12 ro root=/dev/hda2
	initrd /boot/initrd-2.4.3-12.img
title dark
	rootnoverify (hd0,0)
	chainloader +1
title dark and sticky
	rootnoverify (hd0,0)
	chainloader +1
	savedefault
--------

My grub.conf after the kernel install:

--------
default 0
timeout 10
splashimage (hd0,6)/boot/grub/splash.xpm.gz
title Red Hat Linux (2.4.7-6)
        root (hd0,6)
        kernel /boot/vmlinuz-2.4.7-6 ro root=/dev/hda7
        initrd /boot/initrd-2.4.7-6.img
        savedefault
title roswell (2.4.7-2)
        root (hd0,6)
        kernel /boot/vmlinuz-2.4.7-2 ro root=/dev/hda7
        initrd /boot/initrd-2.4.7-2.img
        savedefault
title seawolf (2.4.3-12)
        root (hd0,1)
        kernel /boot/vmlinuz-2.4.3-12 ro root=/dev/hda2
        initrd /boot/initrd-2.4.3-12.img
title dark
        rootnoverify (hd0,0)
        chainloader +1
title dark and sticky
        rootnoverify (hd0,0)
        chainloader +1
        savedefault
--------

Since I modify grub.conf, I don't necessarily expect automatic
modifications to it to Do The Right Thing with respect to my intentions,
but they shouldn't go around changing my defaults.  On the other hand,
maybe it should make itself the default, but probably not if default=saved.
 Obviously someone who has edited grub.conf to change defaults around
probably knows at least a little about what they are doing though....
Comment 1 Arjan van de Ven 2001-08-31 17:42:53 EDT
mkinitrd actually does the grub.conf editing -> reassigning
Comment 2 Jeremy Katz 2001-09-05 16:49:15 EDT
Should be fixed in mkinitrd-3.2.6-1 at
http://people.redhat.com/~katzj/mkinitrd-3.2.6-1.i386.rpm.  If this doesn't fix
it, please let me know.

Note You need to log in before you can comment on or make changes to this bug.