Bug 529992 - PartitionException: No space left on device during write on /dev/vda
PartitionException: No space left on device during write on /dev/vda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
anaconda_trace_hash:588d483785741fbcc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-21 00:27 EDT by Amit Shah
Modified: 2010-03-06 11:32 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 05:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (23.15 KB, text/plain)
2009-10-21 00:27 EDT, Amit Shah
no flags Details
Attached traceback automatically from anaconda. (49.24 KB, text/plain)
2009-11-17 17:08 EST, Lawrence Graves
no flags Details
Attached traceback automatically from anaconda. (178.50 KB, text/plain)
2010-01-10 17:53 EST, Kurt Gochko
no flags Details
Attached traceback automatically from anaconda. (69.12 KB, text/plain)
2010-03-06 11:20 EST, Mickey Chandler
no flags Details

  None (edit)
Description Amit Shah 2009-10-21 00:27:12 EDT
The following was filed automatically by anaconda:
anaconda 12.38 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/__init__.py", line 290, in freshDisk
    peddisk = disk_new_fresh(device.getPedDevice(), ty)
  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 30, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in freshDisk
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 96, in freshPartedDisk
    return parted.freshDisk(device=self.partedDevice, ty=labelType)
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 114, in partedDisk
    self._partedDisk = self.freshPartedDisk()
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 68, in __init__
    self._origPartedDisk = self.partedDisk.duplicate()
  File "/usr/lib/anaconda/storage/formats/__init__.py", line 90, in getFormat
    fmt = fmt_class(*args, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1333, in handleUdevDiskLabelFormat
    exists=False)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1277, in addUdevDevice
    self.handleUdevDiskLabelFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1963, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 339, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 81, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1195, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: No space left on device during write on /dev/vda
Comment 1 Amit Shah 2009-10-21 00:27:27 EDT
Created attachment 365458 [details]
Attached traceback automatically from anaconda.
Comment 2 Amit Shah 2009-10-21 00:31:31 EDT
Installing within a kvm guest, from the qemu.git repo; qemu command line:

./x86_64-softmmu/qemu-system-x86_64 -m 1G -drive if=/guests/f12-beta.qcow2,if=virtio -net user -net nic,model=virtio -boot d -cdrom ~/images/F12-Beta-x86_64-Live.iso -enable-kvm
Comment 3 Chris Lumens 2009-10-21 11:54:12 EDT
How big is /guests/f12-beta.qcow2?
Comment 4 Amit Shah 2009-10-21 13:25:40 EDT
10G (it's a sparse file; but that doesn't matter).
Comment 5 Amit Shah 2009-10-21 13:32:34 EDT
BTW it works with ide, ie this works:

./x86_64-softmmu/qemu-system-x86_64 -m 1G /guests/f12-beta.qcow2 -net user -net nic,model=virtio -boot d
-cdrom ~/images/F12-Beta-x86_64-Live.iso -enable-kvm

(but -drive file=/guests/f12-beta.qcow2,if=ide didn't work, giving the same error as that of virtio; scratching head about that)
Comment 6 Chris Lumens 2009-10-22 08:27:50 EDT
As you can see in the traceback and reproduced below, the size information being provided to parted (and therefore to anaconda) is incorrect.  It appears to be a drive of 0 sectors, which means we can't possibly do anything with it - we are correct here in saying that there's no space left.  The fact that it works with IDE but not with virtio in some setups leads me to believe this is a qemu problem.

device: parted.Device instance --
  model: Virtio Block Device  path: /dev/vda  type: 15
  sectorSize: 512  physicalSectorSize:  512
  length: 0  openCount: 0  readOnly: False
  externalMode: False  dirty: False  bootDirty: False
  host: 0  did: 0  busy: False
  hardwareGeometry: (32716, 57805760, 0)  biosGeometry: (0, 4, 32)
  PedDevice: <_ped.Device object at 0x37e8200>
Comment 7 Amit Shah 2009-10-22 08:37:07 EDT
Agreed; it's probably related to extboot.
Comment 8 Glauber Costa 2009-10-23 07:24:19 EDT
I've got one of those the other day. And in the end, it was a result of I/O errors on the file, because it was placed over an NFS mount.

So, are you by any chance using a strange setup that could lead to that?
Comment 9 Amit Shah 2009-10-23 07:33:45 EDT
No; But I'm using upstream qemu.git and qemu-kvm.git. Maybe this bug doesn't exist in the Fedora qemu-kvm; I haven't checked (yet). Will do so sometime soon.
Comment 10 Mark McLoughlin 2009-10-23 09:55:02 EDT
Okay, please let us know what you find, either way
Comment 11 Amit Shah 2009-10-26 05:33:00 EDT
Oh well:

(In reply to comment #2)
> Installing within a kvm guest, from the qemu.git repo; qemu command line:
> 
> ./x86_64-softmmu/qemu-system-x86_64 -m 1G -drive
> if=/guests/f12-beta.qcow2,if=virtio -net user -net nic,model=virtio -boot d
> -cdrom ~/images/F12-Beta-x86_64-Live.iso -enable-kvm  

-drive file=... is the correct way to do this. qemu should complain about options it doesn't recognise!
Comment 12 Lawrence Graves 2009-11-17 17:08:43 EST
Created attachment 369969 [details]
Attached traceback automatically from anaconda.
Comment 13 Kurt Gochko 2010-01-10 17:53:11 EST
Created attachment 382887 [details]
Attached traceback automatically from anaconda.
Comment 14 Mickey Chandler 2010-03-06 11:20:35 EST
Created attachment 398225 [details]
Attached traceback automatically from anaconda.
Comment 15 Mickey Chandler 2010-03-06 11:32:32 EST
I was trying to install to an IDE drive from the DVD.  I'm not sure why this isn't working, but I certainly would like to get it working.

Note You need to log in before you can comment on or make changes to this bug.