Bug 530201 - Huawei E160 only works once
Summary: Huawei E160 only works once
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-21 20:43 UTC by Laurence
Modified: 2010-02-09 01:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-09 01:48:14 UTC
Type: ---


Attachments (Terms of Use)
/var/log/messages (67.89 KB, text/plain)
2009-10-21 20:43 UTC, Laurence
no flags Details

Description Laurence 2009-10-21 20:43:46 UTC
Created attachment 365603 [details]
/var/log/messages

Description of problem:

If I plug my mobile broadband dongle into my laptop, I can configure a connection using network manager, it connects fine. If I then disconnect and reconnect, it fails.

Version-Release number of selected component (if applicable):

Fedora 12 beta

How reproducible:

Every time

Steps to Reproduce:
1. Plug in E160 dongle
2. Configure and connect via networkmanager
3. Disconnect
4. Reconnect

Actual results:

Can't connect the second time

Expected results:

Able to connect the second time
Additional info:

Comment 1 Bug Zapper 2009-11-16 13:59:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Mohamed M. Hagag 2009-11-20 21:29:26 UTC
I've the same problem with F12, i think that udev shouldn't mount the USB CD-ROM or even initiate it, to solve this issue, but i don't know how to do this.

anyone can help ??


Thanks & Best Regards,

Comment 3 Mohamed M. Hagag 2009-11-20 21:33:56 UTC
sorry, forget to mention that my 3G Modem is Huawei 220/270 USB Stick, which is a composite USB device contains a USB CD-ROM - which contains the windows driver - and a Micro SD Card reader plus the 3G Modem.

this device is working nicely with F11 but starting with F12 it has this problem.

Comment 4 bobpoljakov 2009-11-21 14:34:39 UTC
Similar problem exists here with Huawei e870. When i plug it in, it is recognized as usb cd-rom, and nm can't connect, when i unmount the device, it works sometime. There were no similar problem with fedora 11, problems started after upgrade to 12.

Comment 5 Edgar Bertoti 2009-12-25 15:03:44 UTC
Similar problem exists under fc12 using a Huawei E1752 modem (under fc11 it works fine). The problem is that the device works only once after reboot, but not when I disconnect and reconnect it, or making suspend/hibernation when it is plugged.

Looking into the log files it can be seen that the device is recognized as cd-rom and a /dev/sr1 is created after the boot process (and sr0 is for the standard cd-rom device). After disconnecting (ejecting or unmounting) and reconnecting, the device is not recognized at all, not even as any type of usb devices. The main problem can be that the system is not able to create the sr1 device (only sr0 is present) after reconnectin it.

Note that Huawei E169 work fine under fc12 and the same applies for a ZTE MF110 device.

Comment 6 bobpoljakov 2009-12-25 21:48:37 UTC
I had similar problem with my Huawei E870. I found a workaround. My card uses the option kernel module. If I remove and then load again that module, and unplug/plug my card, it is recognized again.

Comment 7 Edgar Bertoti 2009-12-30 18:50:32 UTC
Thanks for the idea. It was not the option module for me, but the usb_storage module. The solution I found is the following: when I disconnect from the net and then unmount/eject the Huawei E1752, I also have to remove the usb_storage module. Then, after plugging the device, everything is OK again, although the device recognition is rather slow (as ever). If I don't unplug the device, the usb_storage module should be loaded manually. Now I have to find some way to do all this stuff automatically. Any help would be appreciated.

Comment 8 Dan Williams 2010-01-03 00:42:49 UTC
You can also use the usb_modeswitch package to ensure the device is flipped to modem mode.  After that, it should be recognized by ModemManager as a mobile broadband device.

As to the issue of not reconnecting after having disconnected, please try the lastest ModemManager updates which fix this issue.  "yum update ModemManager" will pull those down for you.

If you're still having problems, please note which specific version of ModemManager and NetworkManager you're using.  Thanks!

Comment 9 Edgar Bertoti 2010-01-03 16:20:52 UTC
After upgrading to
ModemManager-0.2.997-4.git20091218.fc12.x86_64
NetworkManager-0.7.997-2.git20091214.fc12.x86_64
I have the same problem described above using Huawei E1752, i.e., after disconnecting (and ejecting/unmounting) and reconnecting it, the device is not recognized at all, not even as any type of usb device. I have to remove the module usb_storage and then reload it again (while the devices is plugged) and then it is recognized as a cd-rom (sr1). At this stage I can use the usb-modeswitch command to flip to modem mode (the usb_modeswitch command has always been needed).

Comment 10 Dan Williams 2010-01-21 02:07:57 UTC
Laurence, is your connect/disconnect problem fixed with latest ModemManager and NetworkManager updates?

Comment 11 Laurence 2010-01-31 15:13:41 UTC
Works fine now. Many thanks Dan!


Note You need to log in before you can comment on or make changes to this bug.