Bug 53047 - rpm segfaults on --rebuilddb
rpm segfaults on --rebuilddb
Status: CLOSED DUPLICATE of bug 53048
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-02 13:33 EDT by Brad Cox
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-02 13:33:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Cox 2001-09-02 13:33:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; 0.8.1)
Gecko/20010421

Description of problem:
I've been living with a corrupt db ever since trying ximian red-carpet.
I've read similar reports in bugzilla and tried everything mentioned there,
including db_dump Packages.old | db_load Packages. Even tried the txxxxx.c
program mentioned in one of them, replacing the record numbers hardcoded in
with record numbers reported by db_verify Packages.old. Latest try was to
download rpm 4.03 from ftp.rpm.org test directory, which is the version
being loaded below. Symptoms are identical regardless the rpm version

rpm -vv --rebuilddb
...(clip)...
D:   +++        384 openssh-askpass-2.5.2p2-1.7.2
D: adding "openssh-askpass" to Name index.
D: adding 11 entries to Basenames index.
D: adding "Applications/Internet" to Group index.
D: adding 11 entries to Requirename index.
D: adding 1 entries to Providename index.
Segmentation fault (core dumped)

[root@linux rpm]# db_verify Packages.old 
db_verify: Overflow page 3339 of invalid type
db_verify: Overflow item incomplete on page 4268
db_verify: DB->verify: Packages.old: DB_VERIFY_BAD: Database verification
failed

db_verify runs silently on all /var/lib/rpm files EXCEPT for
Packages.old. Packages.old is a copy of Packages. Packages is a copy built
by db_dump Packages.old | db_load Packages


 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuilddb -vv
2.with rpm2.tgz (to be attached)
3.
	

Actual Results:  D:   +++        384 openssh-askpass-2.5.2p2-1.7.2
D: adding "openssh-askpass" to Name index.
D: adding 11 entries to Basenames index.
D: adding "Applications/Internet" to Group index.
D: adding 11 entries to Requirename index.
D: adding 1 entries to Providename index.
Segmentation fault (core dumped)
[root@linux rpm]# rpm


Expected Results:  No core dump

Additional info:

[root@linux rpm]# rpm --rebuilddb
Segmentation fault (core dumped)
[root@linux rpm]# which rpm
/bin/rpm
[root@linux rpm]# gdb /bin/rpm core
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...(no debugging symbols
found)...

warning: core file may not match specified executable file.
Core was generated by `/usr/lib/rpm/rpmdb --rebuilddb'.
Program terminated with signal 11, Segmentation fault.
#0  0x40061a03 in ?? ()
(gdb) Quit
(gdb) Quit
(gdb) quit
[root@linux rpm]# gcb /usr/lib/rpm/rpm core
bash: gcb: command not found
[root@linux rpm]# gdb /usr/lib/rpm/rpm core
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux".../usr/lib/rpm/rpm: No such
file or directory.

Core was generated by `/usr/lib/rpm/rpmdb --rebuilddb'.
Program terminated with signal 11, Segmentation fault.
#0  0x40061a03 in ?? ()
(gdb) bt
#0  0x40061a03 in ?? ()
#1  0x40061afd in ?? ()
#2  0x400624dd in ?? ()
#3  0x4006266a in ?? ()
#4  0x40073a20 in ?? ()
#5  0x4007608c in ?? ()
#6  0x8049e4f in ?? ()
#7  0x40167f31 in ?? ()
(gdb)
Comment 1 Jeff Johnson 2001-09-02 13:51:57 EDT

*** This bug has been marked as a duplicate of 53048 ***

Note You need to log in before you can comment on or make changes to this bug.