Bug 53056 - problems with X and KDE
Summary: problems with X and KDE
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-02 20:30 UTC by penguins
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-09-20 13:31:49 UTC


Attachments (Terms of Use)

Description penguins 2001-09-02 20:30:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
X will not respond to keyboard after variable periods of time when running
the kde window manager.  Mouse responds, but unable to switch to text
console.  Can ssh in to check /var/log/messages and dmesg with no reports
in either.  You cannot halt the machine remotely as it drops the network
and just hangs the machine.  Other windowmanagers do not experience this
issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start X running kde
2.run any apps for any period of time
3.X or KDE locks up
	

Actual Results:  X or KDE locks up. Mouse responds, but keyboard does not. 
You can't switch to a text console.  Networking is still running and there
are no errors in /var/log/messages or in dmesg. 

Expected Results:  Should have kept running

Additional info:

If I use any other window manager besides KDE it works fine.  I've used
Gnome, window maker, and xfce without issue.  I have also installed the
updated kde packages with the same results

Comment 1 Bernhard Rosenkraenzer 2001-09-03 10:42:11 UTC
I can't reproduce this; my KDE has been up and running without problems for 
quite a few days.
Since it locks up the whole X server, it might be an driver problem; which 
graphics hardware are you using?


Comment 2 penguins 2001-09-03 16:51:47 UTC
I am running the neomagic 256av chip as found in the ibm 600x thinkpad.  My 
first thought was it may be caused by some of the power management features of 
KDE as I heard somewhere that lmsensors caused problems.  I believe it uses 
nm2200.

Comment 3 penguins 2001-09-05 17:07:22 UTC
XFree86.0.log doesn't report errors either.

Comment 4 penguins 2001-09-05 17:15:05 UTC
actually reference http://www.xfree86.org/pipermail/neomagic/2001-July/000585.html
here are some other people experiencing the same issue.

Comment 5 penguins 2001-09-06 14:39:25 UTC
here's something new I found.  When it 'locks' X takes all the CPU time and
killing X, or whatever display manager doesn't unlock the screen. It keeps the
same content and the only way to get rid of it is reboot.  Now the next
interesting part is that after the 1st reboot if you try to startx or are in
runlevel5 (whatever) it will not bring you to the desktop.  You need to reboot
the machine again to get it to come back up.  The last the the X log shows is it
initializing the mice (I have a trackpoint and a usb mouse). It doesn't give any
errors though, they are simply the last thing in the log.  This is presently
occuring with xfce which uses no kde components.  I rpm -e'd all the kde
software and lmsensors.  Trying that out now.

Comment 6 Ngo Than 2004-09-20 13:31:49 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "CURRENTRELEASE" for now.


Note You need to log in before you can comment on or make changes to this bug.