Bug 53061 - Missing the cfdisk application from rpm
Summary: Missing the cfdisk application from rpm
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 54976 55709 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-03 00:23 UTC by Brian Bruns
Modified: 2007-04-18 16:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-03 01:23:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Bruns 2001-09-03 00:23:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Win98; U)

Description of problem:
The util-linux-2.11f-9 rpm is missing the cfdisk application which is part of the full util-linux package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install util-linux-2.11f-9.(arch).rpm
	

Actual Results:  [root@summit root]# cfdisk
bash: cfdisk: command not found
[root@summit root]# 

Expected Results:  Should have started the cfdisk application

Additional info:

Not sure why it was removed, but it should be placed back into the package because its used by alot of people.

Comment 1 Christian Hechelmann 2001-09-03 01:20:29 UTC
read the changelog. cfdisk was removed in 2.11f-9.


Comment 2 Brian Bruns 2001-09-03 01:23:26 UTC
* Sun Aug 26 2001 Elliot Lee <sopwith@redhat.com> 2.11f-9

- Don't include cfdisk, since it appears to be an even bigger pile of junk than 
fdisk? :)

Yeah, and whats the real reason?  'pile of junk' isn't exactly very descriptive

Comment 3 Elliot Lee 2001-09-03 17:41:28 UTC
cfdisk has some bugs open, and it is either waste time fixing them or tell
people to use fdisk. I prefer to do the latter and put what time I have into
making a single bug-freer fdisk tool, instead of wasting effort on a uselessly
duplicative tool.
If you find cfdisk useful, you are encouraged to rebuild the util-linux package
to include it - that's what free software is all about! :)

Comment 4 Elliot Lee 2001-10-23 21:42:25 UTC
*** Bug 54976 has been marked as a duplicate of this bug. ***

Comment 5 Yanko Kaneti 2001-12-14 09:55:36 UTC
Hmm. I'd rather trust the util-linux maintainer whether cfdisk is crap or not.
Or if it somehow (misteriously) hinders the development of a better partitioning
tool.

The only thing this change here achieves imho is to irritate some longtime
redhat users. Or provide some amusement for new redhat adopters.

I think you should reconsider

Thanks

Comment 6 Elliot Lee 2002-01-04 20:01:48 UTC
*** Bug 55709 has been marked as a duplicate of this bug. ***

Comment 7 David Balažic 2004-10-13 15:45:59 UTC
A bit late, but :

Explanation why cfdisk is crap :
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=28417#c7
( bug 28417 comment 7 )


Note You need to log in before you can comment on or make changes to this bug.