Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 53072 - "Cut" loses data
"Cut" loses data
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnumeric (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 05:13 EDT by Karsten Weiss
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-06 21:32:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Weiss 2001-09-03 05:13:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
Try cutting a cell from a spread sheet and then pasting the
clipboard contents again. It wont work. the cutted cell
contents isnt stored in the clipboard. The cell contents is lost.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.enter text into a cell
2.cut the text
3.try to paste it
	

Actual Results:  cell contents is lost. (Undo doesnt work either)

Expected Results:  the cutted cell contents should be pasted.

Additional info:

There are several other gnumeric bugs which seem to
be fixed in later gnumeric releases (from reading the
ChangeLog).

So it is probably a good idea to upgrade the Raw Hide
release from 0.67 to 0.70.
Comment 1 Owen Taylor 2001-09-03 11:06:08 EDT
Do you know if this particular bug is fixed in later versions?
We won't be doing an upgrade of gnumeric right at the moment
(QA constraints, etc.) but it would be good to know if this
needs to be reported upstream or not.
Comment 2 Karsten Weiss 2001-09-04 05:24:57 EDT
I just created a quick'n dirty gnumeric-0.70 binary rpm and
tested it: The problem is still there. It even became worse
because the cut command doesn't even erase the cell(s) anymore.
Comment 3 Karsten Weiss 2001-09-04 08:30:45 EDT
I've also filed the bug report in the GNOME Bug Tracker. Bug #60000. :-)
Comment 4 Wayne Schuller 2002-01-06 21:32:33 EST
Actually this bug is fixed in gnumeric 0.68.

We had a number of people that submitted it to gnome bugzilla and the bug has
been  resolved and closed there for a few months.

http://bugzilla.gnome.org/show_bug.cgi?id=57118

http://bugzilla.gnome.org/show_bug.cgi?id=60000
Comment 5 Owen Taylor 2002-01-24 10:53:56 EST
There are now gnumeric-1.0 packages in rawhide and 
in ftp://people.redhat.com/hp/gnomehide that should have
the upstream fixes.

Note You need to log in before you can comment on or make changes to this bug.