Bug 53081 - Installer gets DHCP'ing hostnames wrong
Installer gets DHCP'ing hostnames wrong
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 08:42 EDT by Joshua Jensen
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 22:25:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2001-09-03 08:42:58 EDT
Description of Problem:

I've done two installs or RC2 onto two different machines that are DHCP 
clients.  One install was text-based via ftp, the the other a GUI install 
via NFS.  The problems is that I was never prompted for the name of the 
machine, and after an otherwise good installation, the machine reboots 
and is "localhost.localdomain".  /etc/sysconfig/network has 
HOSTNAME=localhost.localdomain, and /etc/hosts only has the one 127.0.0.1 
line.

It's annoying to boot to "localhost" named machines.

Version-Release number of selected component (if applicable):

RC2

How Reproducible:

Install to a DHCP'ing host
Comment 1 Michael Fulbright 2001-09-04 14:36:02 EDT
This is probably a dupe of this issue, it comes up from time to time.
Comment 2 Jeremy Katz 2001-09-04 15:31:31 EDT
Do you have working reverse DNS for your DHCP'd hosts?  With DHCP, we use the
reverse dns given and otherwise fallback to localhost.localdomain.  This is the
most predictable and the most "correct" way to avoid breaking apps
Comment 3 Joshua Jensen 2001-09-04 22:25:35 EDT
Ah... that explains it.  The two IPs that I used to install RC2 did not have reverse 
resolutions.  But many IPs won't have PTR reverse-records... why not prompt for a 
hostname in those cases?  Couldn't you just place the user-supplied hostname on 
the 127.0.0.1 line in /etc/hosts?:
127.0.0.1	localhost hostname localhost.localdomain

My thinking behind this is that we don't always get the same IP if we use DHCP 
(reverse lookups aside),  but we do always have loopback (which is the entire 
point of loopback).
Comment 4 Jeremy Katz 2001-09-05 13:06:28 EDT
This breaks several applications and we've been around this half a dozen other
times.  Answer -- if using dhcp, make dns work, otherwise fix /etc/hosts
yourself and pick up the pieces of the apps that break :)  It's, unfortunately,
the best solution at the present time.

Note You need to log in before you can comment on or make changes to this bug.