Bug 53082 - installation fails during upgrade of corrupt installation
installation fails during upgrade of corrupt installation
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 09:05 EDT by gitesh
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-03 09:05:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gitesh 2001-09-03 09:05:45 EDT
Description of Problem:
While upgrading a system with corrupt file system the installer crashes 
and logs in a file ANACDUMP. The installer asks to report at 
bugzilla.redhat.com

I had a working linux system (Acer Veriton 5100)in which the file system 
became corrupt because of power failure. The machine could not be booted. 
After the intial startup screen system said - dropping to shell...enter 
root password for maintainence or press Ctrl-D. I ran fsck manually. Still 
it did not boot. Then I tried to upgrade the system so as to update the 
filesystem

Version-Release number of selected component (if applicable):

How Reproducible:
Boot the system with CD and run upgrade in installer program. 

Steps to Reproduce:
1. Boot the system with RHL7.0 CD.
2. Choose upgrade in installation.
3. 

Actual Results:
Installer crashes with this message in ANACDUMP file:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1477, in 
doInstall
    f = open(self.instPath + "/etc/mtab", "w+")
IOError: [Errno 5] Input/output error: '/mnt/sysimage/etc/mtab'

Local variables in innermost frame:
self: <todo.ToDo instance at 82691f8>
arch: i386

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Expected Results:
Successful upgrade.

Additional Information:
Comment 1 Matt Wilson 2001-09-04 10:09:59 EDT
this drive is going bad and was unable to write a file to it.

Note You need to log in before you can comment on or make changes to this bug.