This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 530821 - Syntax error in lease file
Syntax error in lease file
Status: CLOSED DUPLICATE of bug 514828
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-25 09:20 EDT by Mads Kiilerich
Modified: 2009-10-26 04:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 04:18:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/lib/dhclient/dhclient-22eba2e4-ba86-47ca-b152-8b00416d71e7-eth1.lease (326 bytes, text/plain)
2009-10-25 09:20 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-10-25 09:20:44 EDT
Created attachment 366024 [details]
/var/lib/dhclient/dhclient-22eba2e4-ba86-47ca-b152-8b00416d71e7-eth1.lease

Description of problem:

I use NetworkManager for my wireless connection, and it uses dhclient to get an IP address from my (stupid Belkin) wireless access point.

But it seems like it creates a lease file it can't parse:

Oct 25 14:15:10 localhost dhclient: Internet Systems Consortium DHCP Client 4.1.0p1
Oct 25 14:15:10 localhost dhclient: Copyright 2004-2009 Internet Systems Consortium.
Oct 25 14:15:10 localhost dhclient: All rights reserved.
Oct 25 14:15:10 localhost dhclient: For info, please visit http://www.isc.org/sw/dhcp/
Oct 25 14:15:10 localhost dhclient: 
Oct 25 14:15:10 localhost dhclient: /var/lib/dhclient/dhclient-22eba2e4-ba86-47ca-b152-8b00416d71e7-eth1.lease line 11: semicolon expected.
Oct 25 14:15:10 localhost dhclient:   rebind 
Oct 25 14:15:10 localhost dhclient:    ^
Oct 25 14:15:10 localhost dhclient: /var/lib/dhclient/dhclient-22eba2e4-ba86-47ca-b152-8b00416d71e7-eth1.lease line 13: semicolon expected.
Oct 25 14:15:10 localhost dhclient: }
Oct 25 14:15:10 localhost dhclient:  ^
Oct 25 14:15:10 localhost dhclient: /var/lib/dhclient/dhclient-22eba2e4-ba86-47ca-b152-8b00416d71e7-eth1.lease line 13: unterminated lease declaration.
Oct 25 14:15:10 localhost dhclient: }
Oct 25 14:15:10 localhost dhclient:  ^
Oct 25 14:15:10 localhost dhclient: Listening on LPF/eth1/00:16:6f:42:6e:cf
Oct 25 14:15:10 localhost NetworkManager: <info>  dhclient started with pid 11317
Oct 25 14:15:10 localhost dhclient: Sending on   LPF/eth1/00:16:6f:42:6e:cf
Oct 25 14:15:10 localhost dhclient: Sending on   Socket/fallback
Oct 25 14:15:10 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
Oct 25 14:15:10 localhost dhclient: DHCPOFFER from 192.168.2.1
Oct 25 14:15:10 localhost dhclient: DHCPREQUEST on eth1 to 255.255.255.255 port 67
Oct 25 14:15:11 localhost dhclient: DHCPACK from 192.168.2.1
Oct 25 14:15:11 localhost dhclient: bound to 192.168.2.2 -- renewal in 891007136 seconds.

There might be something wrong with the dhcp server, but I would expect it to fail with something more specific than a syntax error in dhclients own cache file.

I also miss information about how serious the syntax error is. Is it just a warning? Or is the lease file completely invalid?


Version-Release number of selected component (if applicable):

dhclient-4.1.0p1-12.fc12.i686
NetworkManager-0.7.996-5.git20091021.fc12.i686
Comment 1 Jiri Popelka 2009-10-26 04:18:37 EDT

*** This bug has been marked as a duplicate of bug 514828 ***

Note You need to log in before you can comment on or make changes to this bug.