Bug 53099 - ntpd after up2date doesn't do what is expected
ntpd after up2date doesn't do what is expected
Status: CLOSED DUPLICATE of bug 50698
Product: Red Hat Public Beta
Classification: Retired
Component: ntp (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 11:14 EDT by Christopher McCrory
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-03 11:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher McCrory 2001-09-03 11:14:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
ntpd after up2date doesn't do what is expected 

It is now running as "ntpd -U' ( drop root privs)

But it is still running as root



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  install and conf ntpd
2.  run up2date, get latest version
3.
	

Actual Results:  ps aux
...
chrismcc 31624  0.0 23.8 95456 60748 ?       S    07:27   0:01
/usr/lib/mozilla/134767660 31727  0.0  0.7 2012 2004 ?        SL   07:29  
0:00 ntpd -U ntp
root     31758  0.0  0.4  2648 1240 ?        S    07:29   0:00 /usr/sbin/sshd
root     31830  0.0  0.8  4024 2256 pts/2    S    07:30   0:00
/usr/sbin/snmpd -root     31886  0.0  0.4  2288 1048 ?        S    07:31  
0:00 xinetd -stayaliveroot     32480  0.0  0.3  2848  904 pts/2    R   
08:15   0:00 ps axu



[root@wednesday root]# lsof | grep -i ntp

ntpd      31727     root  cwd    DIR        8,6     4096          2 /
ntpd      31727     root  rtd    DIR        8,6     4096          2 /
ntpd      31727     root  txt    REG        8,6   252076     425205
/usr/sbin/ntpd
ntpd      31727     root  mem    REG        8,6   454502     393194
/lib/ld-2.2.4.so
ntpd      31727     root  mem    REG        8,6   612909     393195
/lib/libm-2.2.4.so
ntpd      31727     root  mem    REG        8,6   165987     394016
/lib/librt-2.2.4.so
ntpd      31727     root  mem    REG        8,6    44851     457703
/usr/lib/libcap.so.1.10
ntpd      31727     root  mem    REG        8,6  5716199     393096
/lib/libc-2.2.4.so
ntpd      31727     root  mem    REG        8,6   557999     394014
/lib/libpthread-0.9.so
ntpd      31727     root    0u   CHR        1,3              213286 /dev/null
ntpd      31727     root    1u   CHR        1,3              213286 /dev/null
ntpd      31727     root    2u   CHR        1,3              213286 /dev/null
ntpd      31727     root    3u  unix 0xc8d215a0             1176481 socket
ntpd      31727     root    4u  IPv4    1176492                 UDP *:ntp 
ntpd      31727     root    5u  IPv4    1176493                 UDP
localhost:ntp 
ntpd      31727     root    6u  IPv4    1176494                 UDP
wednesday.pricegrabber.com:ntp 




Expected Results:  run as user ntp

root@wednesday root]# grep ntp /etc/passwd
ntp:x:38:38::/etc/ntp:/bin/nologin



Additional info:

[root@wednesday root]# /sbin/service ntpd restart
Shutting down ntpd:                                        [  OK  ]
Synchronizing with time server:                            [  OK  ]
Starting ntpd:                                             [  OK  ]
[root@wednesday root]# lsof | grep -i ntp
innd        967     news    4u  IPv4       3533                 TCP
localhost:nntp (LISTEN)
innd        967     news   14u  unix 0xcb4ab540                3547
/var/run/news/nntpin
ntpd      32594     root  cwd    DIR    8,6     4096          2 /
ntpd      32594     root  rtd    DIR        8,6     4096          2 /
ntpd      32594     root  txt    REG        8,6   252076     425205
/usr/sbin/ntpd
ntpd      32594     root  mem    REG        8,6   454502     393194
/lib/ld-2.2.4.so
ntpd      32594     root  mem    REG        8,6   612909     393195
/lib/libm-2.2.4.so
ntpd      32594     root  mem    REG        8,6   165987     394016
/lib/librt-2.2.4.so
ntpd      32594     root  mem    REG        8,6    44851     457703
/usr/lib/libcap.so.1.10
ntpd      32594     root  mem    REG        8,6  5716199     393096
/lib/libc-2.2.4.so
ntpd      32594     root  mem    REG        8,6   557999     394014
/lib/libpthread-0.9.so
ntpd      32594     root    0u   CHR        1,3              213286 /dev/null
ntpd      32594     root    1u   CHR        1,3              213286 /dev/null
ntpd      32594     root    2u   CHR        1,3              213286 /dev/null
ntpd      32594     root    3u  unix 0xcc0160a0             1207246 socket
ntpd      32594     root    4u  IPv4    1207250                 UDP *:ntp 
ntpd      32594     root    5u  IPv4    1207251                 UDP
localhost:ntp 
ntpd      32594     root    6u  IPv4    1207252                 UDP
wednesday.pricegrabber.com:ntp 


root     32499  0.0  0.5  2540 1396 pts/1    S    08:16   0:00 -bash
134767660 32594  0.0  0.7 2012 2004 ?        SL   08:20   0:00 ntpd -U ntp
chrismcc 32601  0.0 24.0 98164 61456 ?       S    08:20   0:00 /usr/lib/mozilla

ps aux shows userid '134767660' ? ? ?

Maybe I'm just missing something...
Comment 1 Harald Hoyer 2001-09-03 13:45:09 EDT

*** This bug has been marked as a duplicate of 50698 ***

Note You need to log in before you can comment on or make changes to this bug.