Bug 531176 - gnome-screensaver does not show unlock screen after 2nd resume from sleep
gnome-screensaver does not show unlock screen after 2nd resume from sleep
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-27 00:26 EDT by dexterthrowaway
Modified: 2015-01-14 18:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 21:57:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug log of gnome-screensaver during first sleep-wake (12.48 KB, application/octet-stream)
2009-10-30 14:22 EDT, dexterthrowaway
no flags Details
debug log of gnome-screensaver during second sleep-wake (13.01 KB, application/octet-stream)
2009-10-30 14:25 EDT, dexterthrowaway
no flags Details

  None (edit)
Description dexterthrowaway 2009-10-27 00:26:13 EDT
Description of problem:

gnome-screensaver does not show unlock screen after 2nd resume from sleep.

Version-Release number of selected component (if applicable):

gnome-screensaver-2.28.0-5.fc12.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Suspend laptop (Lenovo X61) using either Fn-F4 or closing lid.
2. Press Fn or open lid to wake.
3. Do it a second time.
  
Actual results:

After the 2nd resume from sleep, the screen remains blank, while the LCD is actually backlit. I can type my password, and navigate blindly to restart my computer via (Gnome) Alt-F1, right, right, up, enter, Alt-R.

Expected results:

gnome-screensaver should display unlock screen and work correctly.

Additional info:

As said, when this happens I can blindly do a restart (or even shutdown). I can still access the computer through SSH. No errors in .xsession-errors, Xorg.0.log, messages, etc.

After this happens, multiple sleep-wake cycles still results in blank backlit screen.

Confirmed that it is gnome-screensaver by killing the process before doing multiple sleep-wake cycles. Works as expected without any unlock dialog. Desktop resumes as normal.
Comment 1 dexterthrowaway 2009-10-30 14:22:13 EDT
Created attachment 366838 [details]
debug log of gnome-screensaver during first sleep-wake

The screensaver.log is the debug log for the first sleep-wake cycle on my X61.
Comment 2 dexterthrowaway 2009-10-30 14:25:31 EDT
Created attachment 366841 [details]
debug log of gnome-screensaver during second sleep-wake

The screensaver2.log is the debug log for the second sleep-wake cycle on my X61. I don't know if these are helpful, but they're the only additional information I could think of giving. Don't really know how to read these.

Basically just did the following:

1. gnome-screensaver --no-daemon --debug > screensaver.log 2>&1
2. Sleep my Lenovo X61
3. Wake it
4. Ctrl-C the running gnome-screensaver.
5. gnome-screensaver --no-daemon --debug > screensaver2.log 2>&1
6. Sleep my Lenovo X61 again
7. Wake it again
8. No unlock screen displayed. Blindly just typed my password and blindly restarted my X61.
Comment 3 dexterthrowaway 2009-11-04 01:48:48 EST
Just wanted to say I no longer encounter this with the update to gnome-screensaver-2.28.0-6.fc12.

Seems to be fixed.
Comment 4 Bug Zapper 2009-11-16 09:23:39 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Tim Taiwanese Liim 2010-05-01 00:32:21 EDT
Based on Comment #3, can we close this bug?
Dexter said "Seems to be fixed."

Note You need to log in before you can comment on or make changes to this bug.