Bug 531447 - kpk crash(?) on attempt to update (when clicking OK, apply works)
kpk crash(?) on attempt to update (when clicking OK, apply works)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-28 08:46 EDT by Rex Dieter
Modified: 2009-11-27 16:37 EST (History)
6 users (show)

See Also:
Fixed In Version: 0.5.1.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-27 16:37:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2009-10-28 08:46:48 EDT
rpm -q kpackagekit
kpackagekit-0.5.0.2-1.fc12.x86_64

kpk reported a bunch of updates available this morning, click "select all updates", OK, ... , resolving dependencies => window disappears

Reproduced by selecting a single update, (ktorrent-3.2.5-1 for example).

May be related to drpms somehow.   I was able to successfully install a *new* package.
Comment 1 Rex Dieter 2009-10-28 09:11:25 EDT
Tried out newly released 0.5.0.3 for giggles, problem remained.

On a whim, tried a build without our kpackagekit-0.5.0-defaults_hack.patch , and the failure seemed to go away.  

I'm looking closer at removing some of the extraneous bits from the patch.
Comment 2 Rex Dieter 2009-10-28 09:19:27 EDT
I took out the extraneous const uint stuff, happier now (wtf?) :)
Comment 3 Rex Dieter 2009-10-28 09:21:33 EDT
Scary part is in the midst of testing, and all the crashes, kpk reset to Hourly/Security !

omg, there's a gremlin here, just for giggles, I removed ~/.kde/share/config/KPackageKit 
(due to the above), and now it's not working again.
Comment 4 Rex Dieter 2009-10-28 09:49:04 EDT
More craziness, last data point, reverted to kpk-0.5.0.2, one updates screen, 
* click "apply"  -> works ok
* click "ok"  -> crashy(?) after resolving dependencies.

I've got some other (real work stuff to do), so I'll step away before my frustration here gets the better of me. :)
Comment 5 Rex Dieter 2009-11-02 14:29:46 EST
Retesting kpk-0.5.0.3, still seeing symptoms described in comment #4.  Can anyone reproduce this?
Comment 6 Steven M. Parrish 2009-11-10 11:39:09 EST
I can, the OK key is really extraneous in this case.  All we need is the Apply and Cancel.. Going to work on patching out the OK key unless there are any objections.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Rex Dieter 2009-11-10 11:44:56 EST
OK.

Didn't previous releases treat "OK" the same as apply, except stuff would get hidden/minimized to a systray icon? (ie, it would work in the background out of the way).
Comment 8 Kevin Kofler 2009-11-10 16:00:48 EST
"OK" is supposed to have the same effect as first clicking "Apply", then (once it's done) "Cancel".
Comment 9 Bug Zapper 2009-11-16 09:29:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Fedora Update System 2009-11-17 16:37:34 EST
kpackagekit-0.5.1.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kpackagekit-0.5.1.1-1.fc12
Comment 11 Fedora Update System 2009-11-20 00:25:56 EST
kpackagekit-0.5.1.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kpackagekit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11791
Comment 12 Fedora Update System 2009-11-27 16:37:43 EST
kpackagekit-0.5.1.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.