Bug 53148 - init script exits unless 'NETWORKING_IPV6=yes'
Summary: init script exits unless 'NETWORKING_IPV6=yes'
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: radvd   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-04 16:29 UTC by Ben Levenson
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 23:06:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Levenson 2001-09-04 16:29:28 UTC
Description of Problem:
(The problem is most likely me -- don't know a thing about this RPM)
# service radvd  <-- should return usage
# service radvd status  <-- should return status
nothing happens unless /etc/sysconfig/network contains the following line: 
     NETWORKING_IPV6=yes
Is this intentional? Even if 'NETWORKING_IPV6=yes' was absolutely
necessary for this service to function, I would still expect the status
and usage functions of the script to work.

[root@test122 init.d]# pwd
/etc/rc.d/init.d
[root@test122 init.d]# cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=test122.test.redhat.com
NETWORKING_IPV6=yes
[root@test122 init.d]# ./radvd
Usage: radvd {start|stop|status|restart|reload|condrestart}
[root@test122 init.d]# ./radvd status
radvd is stopped

[root@test122 init.d]# cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=test122.test.redhat.com
#NETWORKING_IPV6=yes
[root@test122 init.d]# ./radvd
[root@test122 init.d]# ./radvd status

Version-Release number of selected component (if applicable):
radvd-0.6.2pl4-1

Comment 1 Pekka Savola 2002-01-17 23:02:36 UTC
There are precedents; e.g. many IPv4 network daemons check that NETWORKING = yes 
before proceeding.  Otherwise the checking might be more complicated.



Note You need to log in before you can comment on or make changes to this bug.