Bug 53159 - misleading error message when EPERM
Summary: misleading error message when EPERM
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd
Version: 7.3
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-04 19:10 UTC by James Manning
Modified: 2005-10-31 22:00 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-09-04 19:10:33 UTC


Attachments (Terms of Use)

Description James Manning 2001-09-04 19:10:29 UTC
Description of Problem:
mistakenly ran mkinitrd as normal user first time, got an error message that 
didn't sound like "permission denied", which was what I expected.

jmm@jmm:/home/jmm> mkinitrd /boot/initrd-2.4.7-6.img 2.4.7-6
All of your loopback devices are in use!
jmm@jmm:/home/jmm> sudo mkinitrd /boot/initrd-2.4.7-6.img 2.4.7-6
Password:
jmm@jmm:/home/jmm> 

Version-Release number of selected component (if applicable):
mkinitrd-3.2.4-1

How Reproducible:
100%

Steps to Reproduce:
1.  run mkinitrd as normal user

Actual Results:
loopback devices in use message

Expected Results:
permission denied error message

Additional Information:
N/A

Comment 1 Erik Troan 2002-01-11 16:38:33 UTC
added better error to mkinitrd 3.3


Note You need to log in before you can comment on or make changes to this bug.