Bug 53177 - pasting text from Mozilla inserts extraneous characters
Summary: pasting text from Mozilla inserts extraneous characters
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-04 21:41 UTC by Chris Ricker
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-17 14:33:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2001-09-04 21:41:31 UTC
Selecting text in Mozilla (using the middle mouse button) and then pasting
it in another X app, such as xterm, often pastes the selected text plus a
prefix of "* ".  ie, high-lighting

This is a test

in mozilla and pasting in xterm will sometimes instead paste

* This is a test

Comment 1 Christopher Blizzard 2002-01-25 20:31:37 UTC
That's a feature, not a bug.  You probably got it from a list.

Comment 2 Chris Ricker 2002-01-25 21:02:25 UTC
I'm not following why it's a feature.  It happens other times than just lists
(ie, it's not just pasting an asterisk in place of a bullet).  It's something
that breaks off and on in Mozilla (I noticed it broken again in a daily build in
the past couple of weeks, for example, though it was fixed by the next daily).

Comment 3 Christopher Blizzard 2002-01-25 21:13:16 UTC
So why is this reopened if it's fixed in daily builds?  0.9.8 will be in rawhide
shortly?

Comment 4 Chris Ricker 2002-01-25 21:45:27 UTC
'cause I'm trying to figure out why it's considered a feature, not a bug, that
mozilla adds characters when pasting text

Comment 5 Christopher Blizzard 2002-01-25 23:07:44 UTC
If you paste a list it's converted into a text friendly format, including *'s to
mark the beginning of items in the list.  That's a feature.  It's there by design.

Can you please provide me with a site and some text to test this bug out against?

Comment 6 Chris Ricker 2002-08-30 12:54:49 UTC
Closing -- haven't seen lately w/ 1.0 CVS / 1.1

Comment 7 Chris Ricker 2002-11-17 05:10:42 UTC
Reopening -- I'm seeing this again.

On the page http://www.zauruszone.com/howtos/lc_ppp-usb.shtml

about a third of the way down the page is text that reads:

"c) Once the kernel has been recompiled and the modules installed, you need to
do the following:

    * Insert the usbserial module : as root, run insmod usbserial vendor=0x4dd
product=0x8002"

When I select just the "insmod usbserial vendor=0x4dd product=0x8002" and paste
it into an xterm, it sometimes pastes as "* insmod usbserial vendor=0x4dd
product=0x8002" (ie, it apparently selects the fact that it was text from a list
item, even though it wasn't the beginning of the list item)

Comment 8 Chris Ricker 2002-11-17 05:15:21 UTC
I'm noticing this on RHL 8.0 with mozilla-1.2b-2002102308_trunk_rh8_xft

Comment 9 Chris Ricker 2003-10-17 14:33:52 UTC
Not seen lately, closing


Note You need to log in before you can comment on or make changes to this bug.