Bug 531944 - Can enable metacity compositing_manager but desktop-effect says no 3D
Can enable metacity compositing_manager but desktop-effect says no 3D
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: desktop-effects (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-29 18:53 EDT by Deji Akingunola
Modified: 2009-10-30 15:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-29 19:08:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deji Akingunola 2009-10-29 18:53:13 EDT
Description of problem: My laptop has an Nvidia Quadro FX 2700M card running the default nouveau driver (identified the card as NVIDIA NV94). I get the shadow, transparency and other effects produced by the metacity compositing manager when I enabled it in gconf, but when I run desktop-effects, the dialog says my hardware doesn't support 3D. 


Version-Release number of selected component (if applicable):desktop-effects-0.8.4-2.fc12.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: Running desktop-effects on the F11 installation on the same laptop, using the nouveau driver, works for me. It allows me to choose between the default WM or compiz.
Comment 1 Owen Taylor 2009-10-29 19:08:11 EDT
The metacity compositing manager doesn't use OpenGL.

In F11, we didn't check for hardware OpenGL, so you'd be able to start Compiz using the nouveau driver, but performance would not be acceptable.
Comment 2 Deji Akingunola 2009-10-29 19:15:14 EDT
(In reply to comment #1)
> The metacity compositing manager doesn't use OpenGL.
> 
> In F11, we didn't check for hardware OpenGL, so you'd be able to start Compiz
> using the nouveau driver, but performance would not be acceptable.  

Understood. I was actually going to use the desktop-effects to try out gnome-shell, does this mean my laptop can run the gnome-shell?
Comment 3 Adel Gadllah 2009-10-30 15:35:04 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > The metacity compositing manager doesn't use OpenGL.
> > 
> > In F11, we didn't check for hardware OpenGL, so you'd be able to start Compiz
> > using the nouveau driver, but performance would not be acceptable.  
> 
> Understood. I was actually going to use the desktop-effects to try out
> gnome-shell, does this mean my laptop can run the gnome-shell?  

No, gnome-shell requires OpenGL we don't have 3D support with the nouveau driver yet. 

It should work using nvidia's binary driver, but as we don't have the source code of it we cannot help if you get any issues with it.

Note You need to log in before you can comment on or make changes to this bug.