Bug 532003 - SELinux is preventing /usr/bin/yelp "execmem" access.
SELinux is preventing /usr/bin/yelp "execmem" access.
Status: CLOSED DUPLICATE of bug 527138
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:cb9347ddac2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-30 05:06 EDT by Karel Klíč
Modified: 2013-03-03 17:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 00:23:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Klíč 2009-10-30 05:06:52 EDT
Souhrn:

SELinux is preventing /usr/bin/yelp "execmem" access.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gnome-help. It is not expected that this
access is required by gnome-help and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Další informace:

Kontext zdroje                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Kontext cíle                 unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Objekty cíle                 None [ process ]
Zdroj                         gnome-help
Cesta zdroje                  /usr/bin/yelp
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          yelp-2.28.0-1.fc12
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.32-35.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31.5-96.fc12.i686.PAE #1 SMP Fri
                              Oct 23 19:39:36 EDT 2009 i686 athlon
Počet upozornění           1
Poprvé viděno               Pá 30. říjen 2009, 10:04:32 CET
Naposledy viděno             Pá 30. říjen 2009, 10:04:32 CET
Místní ID                   4a14af5a-4699-49b9-87ff-73e72bfdc396
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1256893472.421:26790): avc:  denied  { execmem } for  pid=11527 comm="gnome-help" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process

node=(removed) type=SYSCALL msg=audit(1256893472.421:26790): arch=40000003 syscall=192 success=yes exit=3158016 a0=0 a1=1000 a2=7 a3=22 items=0 ppid=1 pid=11527 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=10 comm="gnome-help" exe="/usr/bin/yelp" subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-35.fc12,catchall,gnome-help,unconfined_t,unconfined_t,process,execmem
audit2allow suggests:

#============= unconfined_t ==============
allow unconfined_t self:process execmem;
Comment 1 Karel Klíč 2009-10-30 05:10:08 EDT
This "execmem" access was caused by opening Help->Contents in Empathy messaging client.
Comment 2 Matthias Clasen 2009-11-02 00:23:11 EST

*** This bug has been marked as a duplicate of bug 527138 ***

Note You need to log in before you can comment on or make changes to this bug.