Bug 53201 - reboot command has universal execute permission
Summary: reboot command has universal execute permission
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: usermode   
(Show other bugs)
Version: roswell
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-05 01:52 UTC by archan
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 01:52:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description archan 2001-09-05 01:52:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
[ananda@pagladashu projects]$ ls -l /usr/bin/reboot 
lrwxrwxrwx    1 root     root           13 Aug 29 20:20 /usr/bin/reboot ->
consolehelper
[ananda@pagladashu projects]$ 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
reboot command has universal execute permission

[ananda@pagladashu projects]$ ls -l /usr/bin/reboot
lrwxrwxrwx 1 root root 13 Aug 29 20:20 /usr/bin/reboot -> consolehelper
[ananda@pagladashu projects]$
	

Actual Results:  [ananda@pagladashu projects]$ ls -l /usr/bin/reboot
lrwxrwxrwx 1 root root 13 Aug 29 20:20 /usr/bin/reboot -> consolehelper
[ananda@pagladashu projects]$


Expected Results:  it should only be executed by root

Additional info:

reboot command must only be executed by root otherwise, general user can
reboot the system

Comment 1 Nalin Dahyabhai 2001-11-02 21:07:14 UTC
Symbolic links generally always have all permission bits set, and this is not a
problem.  The permissions on the target of the symbolic link are what matter.

In this case, the consolehelper program runs userhelper, which makes certain
checks (typically, that the user is in fact logged in at the console -- the
assumption being that the user also has access to the power and/or reset buttons
on the CPU case, and an orderly reboot is highly preferable to hitting the reset
button), and can also be configured to prompt for the superuser password, before
allowing the system to be rebooted.  This is the intended behavior.


Note You need to log in before you can comment on or make changes to this bug.