Bug 53216 - up2date disk space computation not sophisticated enough
up2date disk space computation not sophisticated enough
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 01:45 EDT by Havoc Pennington
Modified: 2015-01-07 18:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-06 18:15:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2001-09-05 01:45:16 EDT
The total size of the selected packages (236646 kB) exceeds your free disk
space (79344 kB).
[root@dhcppc1 rhn]# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hdc2               521780    415932     79344  84% /
/dev/hdc1               521748    190960    304284  39% /tmp
/dev/hdc6              6047724   3942416   1798100  69% /usr
none                    385540         0    385540   0% /dev/shm
/dev/hdc7              7085139   4362835   2363886  65% /home
/dev/hdc8              7362735   6233459    756772  90% /cvs
/dev/hda1              2047968   1716768    331200  84% /mnt/win

It's only looking at /, assuming all package data will go on that
partition. yeah my partitions are on crack. nonetheless. ;-)
Comment 1 Bill Nottingham 2001-09-05 09:36:23 EDT
No. It downloads the packages to /var first. That's what the calculation is about.
Comment 2 Adrian Likins 2001-10-24 19:59:33 EDT
*** Bug 53583 has been marked as a duplicate of this bug. ***
Comment 3 Aleksey Nogin 2001-11-03 16:25:58 EST
Note: bug 53583 is not an exact duplicate, it's about up2date not subtructing
already downloaded packages from free space requirements.

BTW, another case where up2date does not compute the free space correctly - when
kernel RPMs are being up2date'd up2date fails to leave enough space for initrd
creation! I had a situation (with Enigma) when up2date failed to account for
initrd and because of that didn't even have space to create grub.conf, so it
left the system with an empty grub.conf...

Note You need to log in before you can comment on or make changes to this bug.