Bug 53221 - netscape is showing scramble char for jp locale in kde
netscape is showing scramble char for jp locale in kde
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 02:15 EDT by Leon Ho
Modified: 2014-03-16 22:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 03:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Ho 2001-09-05 02:15:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
Using fresh installation of re0831.0 with jp locale, netscape will have
scramble chars instead of jp char in kde; netscape in gnome works
perfectly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install re0831.0 with jp locale
2. runs kde; kpersonalize; restart kde
3. run netscape
4. menus are in scramble chars
	

Actual Results:  menus in scramble chars

Expected Results:  menu in japanese chars

Additional info:

I was testing kde throughly for Bug 52943 and found out this bug.

o running netscape in gnome works perfectly; display all the menus in
japanese chars.
o trying to elimate possible path that cause this problem
	- was thinking kde fontguess, tried to delete /etc/qt.fontguess, restart
X, same problem.
	- "xlsfonts | grep jis" shows the required font is loaded
(-misc-*-medium-r-*--14-*-*-*-*-*-*-*)
o may related to Bug 52943?
Comment 1 Yu Shao 2001-09-05 02:54:52 EDT
Weird, With an new JP installation, KDE menus are in English(should be in
Japanese), 
change the locale to Simplified Chinese, reboot machine, change the locale back
to 
Japanese, KDE menus are ok now with the Japanese translations, but Netscape's
menus 
are in scramble characters and it complains:

Warning: Cannot convert string
"-*-gulim-medium-r-*-*-*-100-81-81-*-*-ksc5601.1987-0" to type FontStruct
Warning: Cannot convert string "-*-ar pl mingti2l
big5-medium-r-*-*-*-100-81-81-*-*-big5-0" to type FontStruct
Warning: Cannot convert string "-*-ar pl sungtil
gb-medium-r-*-*-*-100-81-81-*-*-gb2312.1980-0" to type FontStruct
Warning: Cannot convert string
"-*-gulim-bold-r-*-*-*-100-81-81-*-*-ksc5601.1987-0" to type FontStruct
Warning: Cannot convert string "-*-ar pl mingti2l
big5-bold-r-*-*-*-100-81-81-*-*-big5-0" to type FontStruct
Warning: Cannot convert string "-*-ar pl sungtil
gb-bold-r-*-*-*-100-81-81-*-*-gb2312.1980-0" to type FontStruct
Warning: Cannot convert string
"-*-gulim-medium-i-*-*-*-100-81-81-*-*-ksc5601.1987-0" to type FontStruct
Warning: Cannot convert string "-*-ar pl mingti2l
big5-medium-i-*-*-*-100-81-81-*-*-big5-0" to type FontStruct
Warning: Cannot convert string "-*-ar pl sungtil
gb-medium-i-*-*-*-100-81-81-*-*-gb2312.1980-0" to type FontStruct

Looks like something with fonts are wrong?
Comment 2 Leon Ho 2001-09-05 03:04:22 EDT
- Error for menu in English is the Bug 52943
- As far as I see, if font cannot be found for that locale (ie. for JP, will be
-misc-*-medium-r-*--14-*-*-*-*-*-*-* ), then it will try to use the fontguess
fonts and see if it fits (my logical guess, as those fonts only referenced by
the qt fontguess). However for jp installation, those fonts are not installed
(it cannot be used for jp anyway), therefore the errors comes up.

That's why I thought it was related to fontguess. Therefore I tried to delete
/etc/qt.fontguess (only thing that related to fontguess), and restart X (as I
said in the first message), but it does not solve the problem.


cc'ing to bero@redhat.com
Comment 3 Bernhard Rosenkraenzer 2001-09-05 11:09:59 EDT
This is related to the fact that Netscape can't deal with proper charset 
names, but KDE tells it to use them if "Apply fonts and colors to non-KDE 
applications" is selected.

I've changed kpersonalizer in kdebase-2.2-11 to automatically disable that 
feature if a non-iso-8859-{1,15} language is selected.
Comment 4 Leon Ho 2001-09-06 04:21:00 EDT
We have tried kdebase-2.2-11 here, but seem the kcmdesktoprc will be emptied
after the kpersonalize (from non-exist to 0 byte file)

I tried to have the code in kcountrypage.cpp in kpersonalize and seem works
fine. Is it possible other methods has altered the file after the kpersonalize?
Comment 5 Bernhard Rosenkraenzer 2001-09-06 04:29:34 EDT
There's no such thing (kcmdesktoprc).
Do you mean kcmdisplayrc?

Comment 6 Leon Ho 2001-09-06 04:32:15 EDT
Yes it is "kcmdisplayrc"

Note You need to log in before you can comment on or make changes to this bug.