Bug 53245 - kickstart NFS installation hang
kickstart NFS installation hang
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 10:09 EDT by Eric Doutreleau
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 09:07:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Doutreleau 2001-09-05 10:09:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [fr] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
when i try to kickstart install a machine through NFS i just got 
the message server not responding

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot from diskette bootnet.img
2. type linux ks=nfs:installtux.int-evry.fr:/var/ftp/pub/ks/B03/ks.cfg

	

Actual Results:  All is working okay the machine got good ip configuration
but the installation just hang when it s time to get the kickstart file
from NFS

Expected Results:  anaconda should get the kickstart file

Additional info:

i got the following messages from another console

nfs warning: mount version older than kernel 
nfs installatux.int-evry.fr not responding still trying

But when i install from CDROM i can mount the same directory on
the same server without a problem

Moreover when i launch tcpdump on my server i got the messages

15:30:54.231906 eth0 < foulque.int-evry.fr.61903203 >
doutrotux.int-evry.fr.nfs: 128 read fh Unknown/1 [|nfs] (DF)
15:30:54.231906 eth0 > doutrotux.int-evry.fr > foulque.int-evry.fr: (frag
25492:68@8232) (DF)
15:30:54.231906 eth0 > doutrotux.int-evry.fr > foulque.int-evry.fr: (frag
25492:1176@7056+) (DF)
15:30:54.231906 eth0 > doutrotux.int-evry.fr > foulque.int-evry.fr: (frag
25492:1176@5880+) (DF)
15:30:54.231906 eth0 > doutrotux.int-evry.fr > foulque.int-evry.fr: (frag
25492:1176@4704+) (DF)
15:30:54.231906 eth0 > doutrotux.int-evry.fr > foulque.int-evry.fr: (frag
25492:1176@3528+) (DF)
15:30:54.231906 eth0 > doutrotux.int-evry.fr > foulque.int-evry.fr: (frag
25492:1176@2352+) (DF)
15:30:54.231906 eth0 > doutrotux.int-evry.fr > foulque.int-evry.fr: (frag
25492:1176@1176+) (DF)
15:30:54.231906 eth0 > doutrotux.int-evry.fr.nfs >
foulque.int-evry.fr.61903203: reply ok 1168 read (frag 25492:1176@0+) (DF)
15:31:24.231906 eth0 < foulque.int-evry.fr > doutrotux.int-evry.fr: icmp:
ip reassembly time exceeded (DF) [tos 0xc0]
Comment 1 Matt Wilson 2001-09-05 17:15:55 EDT
what OS and version is the NFS server running?
Comment 2 Eric Doutreleau 2001-09-06 03:19:33 EDT
The server is a linux Redhat 7.1 server
package nfs-utils-0.3.1-5
Comment 3 Matt Wilson 2001-09-06 08:16:31 EDT
can other clients reliably use this nfs volume?
Comment 4 Eric Doutreleau 2001-09-06 09:07:18 EDT
Yes
I install other machines with no problems

I have this problem with a specific room
But when i installed this room with CD i
have no problem to use that NFS server
Comment 5 Matt Wilson 2001-09-06 10:10:20 EDT
We do NFS installs every day.  It looks like a network setup problem.
Comment 6 Eric Doutreleau 2001-09-17 09:19:40 EDT
it was indeed a network setup problem that doesn t appear while the server
was a 6.2 box

Note You need to log in before you can comment on or make changes to this bug.