Bug 53247 - up2date -u -nox fails
up2date -u -nox fails
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 10:18 EDT by Pedro Miguel Marques Morais
Modified: 2015-01-07 18:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 13:16:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Miguel Marques Morais 2001-09-05 10:18:20 EDT
Description of Problem:

Running up2date from with -nox to update from rc2 to current fails.
up2date finds a conflict between glibc i386 and glibc i686.
I suppose the same would happen with kernels, but I've already
update to the latest version with the X version.

Version-Release number of selected component (if applicable):

Using latest up2date from the up2date server (got it by manual selection
in X mode)

[root@pmmm up2date]# up2date --nox --version
Red Hat Update Agent v2.6.0
Copyright (c) 1999-2001 Red Hat, Inc.
Licensed under terms of the GPL.

[morais@pmmm cutgest]$ rpm -q up2date
up2date-2.6.0-7.x.37

How Reproducible:

Always

Steps to Reproduce:

update -u -nox

Actual Results:

....
Testing package set / solving RPM inter-dependencies...
########################################
RPM conflict error.  The message was:
Test install failed because of package conflicts:
file /lib/ld-2.2.4.so conflicts between attempted installs of glibc-2.2.4-11 
and glibc-2.2.4-11

Expected Results:

Select glibc-*.i686.rpm and ignore glibc-*.i386.rpm

Additional Information:
Comment 1 Adrian Likins 2001-09-05 13:16:26 EDT
This should be fixed in the next version of the client.
Comment 2 David M. Cook 2002-02-22 12:32:11 EST
Fix: http://www.redhat.com/support/errata/RHBA-2001-119.html

Note You need to log in before you can comment on or make changes to this bug.