Bug 53247 - up2date -u -nox fails
Summary: up2date -u -nox fails
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-05 14:18 UTC by Pedro Miguel Marques Morais
Modified: 2015-01-07 23:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 17:16:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:119 normal SHIPPED_LIVE New up2date and rhn_register clients available 2001-10-03 04:00:00 UTC
Red Hat Product Errata RHBA-2002:140 normal SHIPPED_LIVE Updated up2date and rhn_register packages available 2002-07-11 04:00:00 UTC
Red Hat Product Errata RHSA-2003:177 normal SHIPPED_LIVE : Updated up2date and rhn_register clients available 2003-05-27 04:00:00 UTC

Description Pedro Miguel Marques Morais 2001-09-05 14:18:20 UTC
Description of Problem:

Running up2date from with -nox to update from rc2 to current fails.
up2date finds a conflict between glibc i386 and glibc i686.
I suppose the same would happen with kernels, but I've already
update to the latest version with the X version.

Version-Release number of selected component (if applicable):

Using latest up2date from the up2date server (got it by manual selection
in X mode)

[root@pmmm up2date]# up2date --nox --version
Red Hat Update Agent v2.6.0
Copyright (c) 1999-2001 Red Hat, Inc.
Licensed under terms of the GPL.

[morais@pmmm cutgest]$ rpm -q up2date
up2date-2.6.0-7.x.37

How Reproducible:

Always

Steps to Reproduce:

update -u -nox

Actual Results:

....
Testing package set / solving RPM inter-dependencies...
########################################
RPM conflict error.  The message was:
Test install failed because of package conflicts:
file /lib/ld-2.2.4.so conflicts between attempted installs of glibc-2.2.4-11 
and glibc-2.2.4-11

Expected Results:

Select glibc-*.i686.rpm and ignore glibc-*.i386.rpm

Additional Information:

Comment 1 Adrian Likins 2001-09-05 17:16:26 UTC
This should be fixed in the next version of the client.

Comment 2 David M. Cook 2002-02-22 17:32:11 UTC
Fix: http://www.redhat.com/support/errata/RHBA-2001-119.html


Note You need to log in before you can comment on or make changes to this bug.