Bug 53254 - Win2K entry not created in grub or lilo.conf's
Win2K entry not created in grub or lilo.conf's
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 12:06 EDT by Rob Landry
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 15:50:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rob Landry 2001-09-05 12:06:41 EDT
Description of Problem:

Win2K partitions appear as bootable options during the install; however
post install only Linux appeared in grub and/or lilo.conf
Version-Release number of selected component (if applicable):


How Reproducible:
Not sure, only did the install once


Steps to Reproduce:
1. Install Fairfax after Win2k (with NTFS partitions only)
2. During install selected Win2k as the default OS to boot
3. Complete remainder of install

Actual Results:
Fairfax is the only bootable os listed in the boot loader screens and in
grub/lilo.conf

Expected Results:
If it appears during install as a bootable os then it should get created
within the bootloader config file.

Additional Information:
	I don't actually care if Win2K is supported during install; however it
shouldn't give you the option then not create the entry in the config files.
Comment 1 Jeremy Katz 2001-09-05 13:04:17 EDT
Did you give win2k a label on the boot loader screen during the install?  We
don't by default put any label on bootable NTFS partitions, hence they don't
show up in the menu, but you are given the opportunity to give a label at which
point, it has been added correctly in testing.
Comment 2 Rob Landry 2001-09-05 13:50:33 EDT
I thought I put in "Windows 2000"; with a space.  Can you change the default
image without providing a name?  If I remember correctly I had to give it a name
before it would let me make it the default.
Comment 3 Jeremy Katz 2001-09-05 15:18:02 EDT
Do you have this machine in meridian?  It should require a label to set the
default and spaces should be fine for grub.  Also, which tree was this from
exactly?
Comment 4 Jeremy Katz 2001-09-05 15:21:12 EDT
And with a quick test here, it worked properly for me.
Comment 5 Rob Landry 2001-09-05 15:50:04 EDT
Was this with an NTFS partition?  If so, works for me; just thought I should
enter it in, incase it was really borken.  Like I said; I didn't do the install
more than once to see if it continues to happen.

-Rob
Comment 6 Jeremy Katz 2001-09-05 16:11:23 EDT
Yep, it was an ntfs partition...  *shrug*  cosmic rays perhaps :)

Note You need to log in before you can comment on or make changes to this bug.