Bug 53256 - Anaconda failed during post installation process
Anaconda failed during post installation process
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 12:14 EDT by Stephen Torri
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 12:36:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Installation Attempt on 9/6/2001 (2.34 KB, text/plain)
2001-09-06 13:38 EDT, Stephen Torri
no flags Details

  None (edit)
Description Stephen Torri 2001-09-05 12:14:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.9-ac5 i686; en-US; rv:0.9.1)
Gecko/20010621

Description of problem:
Tried to install RedHat 7.0 on a Alpha PC164SX System. Installation of RPMS
went fine but when anaconda got to the post install it failed with messages
about milo. See the attached file from the dump.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Setup partitions per install guide for Alpha (used fdisk with bsd
lables). /boot = a: (20 MB), swap = b: (250MB), and / = c: (rest of drive)
with the partitions startint at cyclinder 2.
2.Install from CD
3. During post-install anaconda will crash.
	

Actual Results:  See the attached crash file from anaconda

Expected Results:  From the looks of the errors the system should have
installed milo. Yet the instructions for fdisk did not mentioned during
formating of partitions the need for a special partition of milo (other
docs report a need for a 2MB fat partition.

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1737, in
doInstall
    self.milo.write ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/milo.py", line 192, in write
    self.writeAboot ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/milo.py", line 85, in
writeAboot
    f = open (confprefix + "/aboot.conf", 'w')
IOError: [Errno 2] No such file or directory:
'/mnt/sysimage/boot/etc/aboot.conf'

Local variables in innermost frame:
kernelprefix: /
bootDevice: hda1
partition: 1
self: <milo.MiloInstall instance at 1203c4550>
rootDevice: hda3
confprefix: /mnt/sysimage/boot/etc
abootdev: hda

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Matt Wilson 2001-09-05 16:25:14 EDT
it looks like you booted via aboot (SRM console), not MILO.

Is this the case?
Comment 2 Stephen Torri 2001-09-05 19:24:29 EDT
Yes. The system went through a reboot after the installation. At the SRM console
I entered to "boot dka100 -flags 0'. That is how I started the install.
Comment 3 Matt Wilson 2001-09-05 20:36:34 EDT
/boot was an ext2 filesystem, correct?
Comment 4 Stephen Torri 2001-09-05 23:05:27 EDT
a: /boot ext2
b: swap
c: / ext2
Comment 5 Matt Wilson 2001-09-06 00:17:17 EDT
could you ls -l /mnt/sysimage/boot
Comment 6 Stephen Torri 2001-09-06 11:49:00 EDT
ls -l /mnt/sysimage/ reports the following for "boot":

drwxr-xr-x 3 root 0 1024 Feb 06 1996 boot

There is nothing inside /mnt/sysimage/boot.
Comment 7 Matt Wilson 2001-09-06 13:05:08 EDT
that's very, very, very odd.

could you get the /mnt/sysimage/tmp/install.log and send it?  Just copy it to a
floppy and sneakernet it.
Comment 8 Stephen Torri 2001-09-06 13:38:55 EDT
Created attachment 31114 [details]
Installation Attempt on 9/6/2001
Comment 9 Stephen Torri 2001-09-06 13:40:06 EDT
I attached the install.log. I changed the name to add the date into it so that
we can distinguish from any future install attemtps.
Comment 10 Matt Wilson 2001-09-06 15:08:13 EDT
please add the ouput of:

cat /proc/mounts

and try:

touch /mnt/sysimage/boot/foo

Comment 11 Stephen Torri 2001-09-06 20:27:22 EDT
Output of "/proc/mounts

/dev/root     /          ext2    rw 0 0
/proc         /proc      proc    rw 0 0
/dev/pts      /dev/pts   devpts  rw 0 0
/tmp/cdrom    /mnt/source  iso9660 ro 0 0
/tmp/loop     /mnt/runtime iso9660 ro 0 0
/tmp/hda3     /mnt/sysimage ext2 rw 0 0
/tmp/hda1     /mnt/sysimage/boot ext2 rw 0 0
/proc         /mnt/sysimage/proc proc rw 0 0


Output of "touch /mnt/sysimage/boot/foo"

touch: /mnt/sysimage/boot/foo: No such file or directory

I doubled check the directories and /mnt/sysimage/boot does exist. Its just not
letting anything to be created. The permissions should allow root to create the
file.
Comment 12 Matt Wilson 2001-09-07 12:30:58 EDT
do:

umount /mnt/sysimage/boot
mknod /tmp/hda3
e2fsck /tmp/hda3
mke2fs /tmp/hda3
mount /tmp/hda3 /mnt/sysimage/boot
touch /mnt/sysimage/boot/foo

I have no idea what's going on here...
Comment 13 Stephen Torri 2001-09-07 14:09:04 EDT
I am assuming that you want me to mess with the "/boot" partition and not the
root partition?

I did everything you said but I used /tmp/hda1 because that was associated with
the /boot partition. In the end I was able to do "touch /mnt/sysimage/boot/foo".
Success.
Comment 14 Need Real Name 2001-09-18 20:38:16 EDT
I got a post-installation failure that appears to be in anaconda.  I had started
the install using the autoboot.bat file in the dosutils directory on the CD.

Here's the file it told me to write onto a floppy and send to you
(anacdump.txt):

Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 19, in
run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1925, in
doInstall
    self.fstab.umountFilesystems(self.instPath)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 632, in
umountFilesystems
    isys.umount(mntPoint, removeDir = 0)
  File
"/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys.py", line
134, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
ValueError: isys.umount() can only umount by mount point

Local variables in innermost frame:
what: /mnt/sysimage/c
removeDir: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S'1024x768'
p4
sS'progressWindow'
p5
(igui
ProgressWindow
(dp6
S'total'
p7
I310
sS'window'
p8
(igtk
GtkWindow
(dp9
S'_o'
p10

<failed>
Comment 15 Stephen Torri 2001-09-22 22:51:25 EDT
Learned how to boot to the installed RedHat from CD. I was able to install the
basic kernel and aboot. I was almost up to finishing the aboot when custom
fitting a fan caused the machine to grumply refuse to work. Now its in the shop
(bad motherboard or heaven forbid ... CPU).

Note You need to log in before you can comment on or make changes to this bug.