Bug 532592 - qemu-kvm aborts - glibc "stack smashing detected"
qemu-kvm aborts - glibc "stack smashing detected"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
12
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
abrt_hash:076889cc16b64b268f2b4ce8a90...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-02 17:10 EST by Bernie Innocenti
Modified: 2010-02-21 17:53 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-21 17:53:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (9.04 KB, text/plain)
2009-11-02 17:10 EST, Bernie Innocenti
no flags Details

  None (edit)
Description Bernie Innocenti 2009-11-02 17:10:19 EST
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Additional information
======


Attached files
----
backtrace

cmdline
-----
qemu-system-x86_64 -usb -usbdevice tablet -vga vmware -soundhw es1370 -m 1024 -cdrom soas04.iso 


component
-----
qemu


executable
-----
/usr/bin/qemu-system-x86_64


kernel
-----
2.6.31.5.bernie


package
-----
qemu-system-x86-2:0.11.0-9.fc12


reason
-----
Process was terminated by signal 6
Comment 1 Bernie Innocenti 2009-11-02 17:10:22 EST
Created attachment 367225 [details]
File: backtrace
Comment 2 Bug Zapper 2009-11-16 09:56:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Mark McLoughlin 2009-11-19 05:10:39 EST
Thanks for the report Bernie

It looks like stack corruption:

#3  0x00000033058faae7 in __fortify_fail (
    msg=0x3305941006 "stack smashing detected") at fortify_fail.c:32
No locals.


Can you reproduce still? How about without '-vga vmware' or '-soundhw es1370'? Or with '-vnc :0' instead of using SDL?

Are you deliberately running qemu-system-x86_64 rather than qemu-kvm?

You have a custom kernel installed? I'm guess that has nothing to do with it, but if you could reproduce without it that would help

Also, note that we recommend people use e.g. libvirt and virt-viewer rather than running qemu directly.
Comment 4 Bernie Innocenti 2009-12-16 02:44:57 EST
(In reply to comment #3)
> Can you reproduce still? How about without '-vga vmware' or '-soundhw es1370'?
> Or with '-vnc :0' instead of using SDL?

I can still riproduce with qemu-system-x86-0.11.0-12.fc13.x86_64

"-vnc :0" worked without crashing (with or without a vnc client connected).


> Are you deliberately running qemu-system-x86_64 rather than qemu-kvm?

I tried to exclude other factors by using software emulation. qemu-kvm also crashes.

> You have a custom kernel installed? I'm guess that has nothing to do with it,
> but if you could reproduce without it that would help

Now I do have a custom kernel, but I could reproduce the bug also with the stock kernel.


> Also, note that we recommend people use e.g. libvirt and virt-viewer rather
> than running qemu directly.  

Graphics acceleration does not seem to be possible with libvirt & virt-viewer.
Comment 5 Justin M. Forbes 2010-02-15 11:32:53 EST
Any updates on this with the latest qemu from virt-preview? https://fedoraproject.org/wiki/Virtualization_Preview_Repository has details for updating to the virt-preview packages.
Comment 6 Bernie Innocenti 2010-02-21 17:53:45 EST
Both -vga cirrus and -vga vmware work nicely in qemu-kvm 0.12.2, thanks!

Note You need to log in before you can comment on or make changes to this bug.