Bug 53272 - Attempt to relocate package fails
Attempt to relocate package fails
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 18:25 EDT by James Bottomley
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 18:25:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bottomley 2001-09-05 18:25:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.17pre20 i686)

Description of problem:
trying to install a relocatable package (in this case
xmmsskins-1.0-5.noarch.rpm from the powertools CD) dies.  This is the
output:

root@hobholes# mkdir /opt/xmms
root@hobholes# rpm -i --relocate /usr=/opt/xmms xmmsskins-1.0-5.noarch.rpm 
error: can't unlink /optxmms-RPMDELETE: Is a directory
error: can't rename /optxmms to /optxmms-RPMDELETE: Is a directory
error: unpacking of archive failed on file /optxmms: cpio: unlink failed -
Is a directory
root@hobholes# 

This has happened to all packages I've tried to relocate (including 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
rpm -i --relocate /usr=/opt/xmms xmmsskins-1.0-5.noarch.rpm 
	

Actual Results:  error: can't unlink /optxmms-RPMDELETE: Is a directory
error: can't rename /optxmms to /optxmms-RPMDELETE: Is a directory
error: unpacking of archive failed on file /optxmms: cpio: unlink failed -
Is a directory


Expected Results:  Package should install in relocated location

Additional info:

rpm -v is 4.0.2 (the standard rpm on RedHat 7.1).  This problem doesn't
occur with rpm 4.0 which is standard on RedHat 7.0

This is a high priority for us because we advertise our rpm packaged
products as relocatable and this bug means that they cannot be relocated on
RH 7.1
Comment 1 Jeff Johnson 2001-09-06 08:30:02 EDT
Yup, broken in rpm-4.0.2, fixed in rpm-4.0.3-0.6 (and later).

Try installing latest rpm-4.0.3 packages from Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.