This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 532731 - imsettings configuration executed several times during a login
imsettings configuration executed several times during a login
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-03 11:33 EST by Marko Myllynen
Modified: 2009-11-03 21:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-03 21:50:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2009-11-03 11:33:59 EST
[Reporting this after a discussion with Jens over IRC]

Description of problem:
While investigating bug 505100 it was noticed that if one puts a simple "echo none.conf >> /tmp/foo" into /etc/X11/xinit/xinput.d/none.conf and no Input Method is in use it gets printed 5 times if ~/.xinputrc is a symbolic link to /etc/X11/xinit/xinput.d/none.conf and 10 times if no ~/.xinputrc exist (i.e., the default). Is this intentional?

Also, GTK_IM_MODULE=xim setting does not seem to propagate into the user environment in terminals while other settings like QT_IM_MODULE. Nevertheless XIM seems to be in use even without it.

Version-Release number of selected component (if applicable):
Fedora Rawhide as of 2009-11-03
Comment 1 Akira TAGOH 2009-11-03 21:50:25 EST
It's not a bug. it's being read when imsettings-daemon:

 1. starts monitoring on /etc/X11/xinit/xinput.d to provide the information certainly if the request is being attempted before receiving any events from the monitor.
 2. starts monitoring on /etc/X11/xinit/xinputrc.
 3. gets any events from the monitor on /etc/X11/xinit/xinput.d
 4. gets any events from the monitor on /etc/X11/xinit/xinputrc
 5. reads the system default configuration.

(In reply to comment #0)
> Also, GTK_IM_MODULE=xim setting does not seem to propagate into the user
> environment in terminals while other settings like QT_IM_MODULE. Nevertheless
> XIM seems to be in use even without it.

It's also not a bug on the certain desktop like GNOME and XFCE. the IM configuration will be sent to the GTK+ applications through XSETTINGS. no need to set up GTK_IM_MODULE for them.

Note You need to log in before you can comment on or make changes to this bug.