Bug 5335 - dd fails on 2GB disks (write only)
dd fails on 2GB disks (write only)
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-23 14:35 EDT by michaelg
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-16 16:13:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michaelg 1999-09-23 14:35:44 EDT
When reading large files > 2Gb it works fine, but writing
gives an error when using SEEK.

E.g. a 4 Gb disk on /dev/hdc:

# dd if=/dev/zero of=/dev/hdc bs=1M seek=4000 count=1

gives an invalid arguement error.

Thanks
Michael
Comment 1 Erik Troan 2000-02-16 16:13:59 EST
This can't be fixed until 64-bit file support is integrated into the standard
Linux kernel due to dd semantics (we need ftruncate64())

Note You need to log in before you can comment on or make changes to this bug.