Bug 53353 - sysconfdir is hardcoded to /etc/rpm
Summary: sysconfdir is hardcoded to /etc/rpm
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-07 07:44 UTC by SL Baur
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-07 07:46:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
./configure --sysconfdir= patch (920 bytes, patch)
2001-09-07 07:46 UTC, SL Baur
no flags Details | Diff

Description SL Baur 2001-09-07 07:44:34 UTC
Description of Problem:
sysconfdir is hardcoded to /etc/rpm in configure.

Version-Release number of selected component (if applicable):
rpm-4.0.3/CVS

How Reproducible:
Attached is a patch to fix this.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 SL Baur 2001-09-07 07:46:04 UTC
Created attachment 31214 [details]
./configure --sysconfdir= patch

Comment 2 Jeff Johnson 2002-03-19 19:44:23 UTC
This patch won't work because the value for
--sysconfdir is used to generate configuration
files. Basically /etc is needed, not /etc/rpm,
so that the macro %{_sysconfdir} gets the right value.


Note You need to log in before you can comment on or make changes to this bug.