Bug 53355 - ifdown-ipv6 tries to sysctl unknown keys
ifdown-ipv6 tries to sysctl unknown keys
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-07 05:05 EDT by Pekka Savola
Modified: 2014-03-16 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 23:14:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
only try to set sysctl values if the corresponding device still exists (705 bytes, patch)
2001-09-07 05:06 EDT, Pekka Savola
no flags Details | Diff

  None (edit)
Description Pekka Savola 2001-09-07 05:05:24 EDT
Under certain, unclear scenarios (this has come up two-three times, but
I've never
managed to pin it down, no matter what), when doing 'ifdown <ipv6-device>' 
you get like:

error: 'net.ipv6.conf.sit0.forwarding' is an unknown key
error: 'net.ipv6.conf.sit0.accept_ra' is an unknown key
error: 'net.ipv6.conf.sit0.accept_redirects' is an unknown key

, because the interface has already been deleted. A good (open) question
is, why this
only happens rather rarely.

These should probably be hidden.  It can be done with the attached patch.
Comment 1 Pekka Savola 2001-09-07 05:06:09 EDT
Created attachment 31215 [details]
only try to set sysctl values if the corresponding device still exists
Comment 2 Bill Nottingham 2002-04-12 16:31:28 EDT
This has to be fixed by now. In any case, 6.63-1 will add '-e' to all the
invocations.

Note You need to log in before you can comment on or make changes to this bug.