Bug 533755 - KPackagekit takes very long to start up
KPackagekit takes very long to start up
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-08 19:00 EST by Martin Kho
Modified: 2009-11-27 16:38 EST (History)
8 users (show)

See Also:
Fixed In Version: 0.5.1.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-27 16:38:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2009-11-08 19:00:30 EST
Description of problem:
KPackagekit - standalone and from systemsettings - take ~25 seconds to start up. According to Steven Parrish it's caused by 'some underlying changes that were made to PackageKit and its daemon. Kpackagekit is having to wait until it receives the appropriate msg from Packagekit via dbus that the daemon is running and ready.' A discussion about this issue can be found at [1]

[1] http://lists.fedoraproject.org/pipermail/fedora-kde/2009-November/004487.html

Version-Release number of selected component (if applicable):
kpackagekit-0.5.0.3-1.fc12.x86_64.rpm
PackageKit-0.5.4-0.1.20091029git.fc12.x86_64.rpm

How reproducible:
Start KPackagekit as standalone application or
from within Systemsettings (-> Add and Remove Software)
  
Actual results:
~25 seconds delay (is seems nothing happens)

Expected results:
1-2 seconds delay is acceptable.

Additional info:
Comment 1 Richard Hughes 2009-11-09 04:35:47 EST
(In reply to comment #0)
> Description of problem:
> KPackagekit - standalone and from systemsettings - take ~25 seconds to start
> up. According to Steven Parrish it's caused by 'some underlying changes that
> were made to PackageKit and its daemon. Kpackagekit is having to wait until it
> receives the appropriate msg from Packagekit via dbus that the daemon is
> running and ready.' A discussion about this issue can be found at [1]

I'm not sure that's 100% correct. The daemon should startup in less than 200ms, and the problem isn't also present in gnome-packagekit, which uses the same service.
Comment 2 Martin Kho 2009-11-09 06:24:12 EST
yes, I've seen no delays with gnome-packagekit. But any ideas to which component I've to file a bug then? Dbus? KPackagekit? Other?

Martin Kho
Comment 3 Justin Newman 2009-11-11 14:53:20 EST
Just confirming that the issue exists for me as well and wasn't present in Fedora 11.
Comment 4 Steven M. Parrish 2009-11-17 08:03:25 EST
I've talked with upstream, and this will be fixed in the next release due shortly.
Comment 5 Fedora Update System 2009-11-17 16:37:39 EST
kpackagekit-0.5.1.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kpackagekit-0.5.1.1-1.fc12
Comment 6 Martin Kho 2009-11-17 16:51:31 EST
Hi,

Installed kpackagekit-0.5.1.1-1.fc12 and the issue is solved, no delays.

Thanks for the good work!

Martin Kho
Comment 7 Fedora Update System 2009-11-20 00:26:07 EST
kpackagekit-0.5.1.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kpackagekit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11791
Comment 8 Fedora Update System 2009-11-27 16:37:48 EST
kpackagekit-0.5.1.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.