Bug 533807 - Crash in glXDestroyContext (vboxvideo)
Crash in glXDestroyContext (vboxvideo)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: desktop-effects (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:e47aa3a1b0eca5895e84e30da6c...
:
: 553617 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 05:43 EST by Michael J. Ayers
Modified: 2010-07-07 13:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: desktop-effects-0.8.7-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 13:48:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.11 KB, text/plain)
2009-11-09 05:43 EST, Michael J. Ayers
no flags Details

  None (edit)
Description Michael J. Ayers 2009-11-09 05:43:42 EST
abrt detected a crash.

Comment: Was attempting to start Desktop Effects in a VirtualBox environment.
Attached file: backtrace
cmdline: desktop-effects
component: desktop-effects
executable: /usr/bin/desktop-effects
kernel: 2.6.31.5-122.fc12.x86_64
package: desktop-effects-0.8.4-2.fc12
rating: 4
reason: Process was terminated by signal 11
Comment 1 Michael J. Ayers 2009-11-09 05:43:44 EST
Created attachment 368169 [details]
File: backtrace
Comment 2 Owen Taylor 2009-11-09 15:42:24 EST
Is this reproducable? Can you repeat it after doing 'debuginfo-install desktop-effects' (debuginfo-install is in the yum-utils package)
Comment 3 Michael J. Ayers 2009-11-09 23:30:08 EST
100% reproducable.  Crashes every time I start it no matter what modules I have loaded.  Looking through much of the error logs I am leaning towards thinking this is an issue with the vboxvideo driver module.  I'll do a debuginfo run tomorrow and see what that will turn up.
Comment 4 Karel Klíč 2010-02-24 12:03:50 EST
*** Bug 553617 has been marked as a duplicate of this bug. ***
Comment 5 Owen Taylor 2010-06-23 09:31:13 EDT
In the case where glXChooseVisual() fails, an uninitialized value for context is passed to glXDestroyContext(), which is almost certainly triggering this crash.
Comment 6 Fedora Update System 2010-06-23 13:22:46 EDT
desktop-effects-0.8.7-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/desktop-effects-0.8.7-2.fc13
Comment 7 Fedora Update System 2010-06-24 12:35:08 EDT
desktop-effects-0.8.7-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update desktop-effects'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/desktop-effects-0.8.7-2.fc13
Comment 8 James Laska 2010-06-30 10:17:42 EDT
Michael: Are you able to confirm this problem is fixed using the update posted in comment#7?  Please feel free to add feedback either here in bugzilla, or at http://admin.fedoraproject.org/updates/desktop-effects-0.8.7-2.fc13

Thanks!
Comment 9 Andre Robatino 2010-07-06 11:36:53 EDT
I'm experiencing the same bug as the OP in F13 x86_64 running as a VirtualBox 3.2.6 guest (PUEL version).  Filed abrt backtrace as bug 611821.
Comment 10 Fedora Update System 2010-07-07 13:48:14 EDT
desktop-effects-0.8.7-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.