Bug 53395 - cpqarray geometry reporting via ioctl broken
Summary: cpqarray geometry reporting via ioctl broken
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 54048 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-07 20:34 UTC by Matt Wilson
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 19:09:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fdisk output (400 bytes, text/plain)
2001-09-07 20:39 UTC, Matt Wilson
no flags Details

Description Matt Wilson 2001-09-07 20:34:25 UTC
fdisk /dev/ida/c0d0 reports geometry of 1/111920/1 -- this doesn't look right.

fdisk only allows you to make a 1 cyl partition.

Comment 1 Michael K. Johnson 2001-09-07 20:36:31 UTC
We haven't reved this driver for a while, and it seems to work in most
cases.  Are you sure this is generic?  I did an install fairly recently
on a machine with a cpqarray card, including partitioning the disk, and
it worked just fine.

Comment 2 Matt Wilson 2001-09-07 20:39:28 UTC
Created attachment 31275 [details]
fdisk output

Comment 3 Matt Wilson 2001-09-07 20:57:54 UTC
another machine, 2.4.7-10smp:
[msw@pitr /tmp]$ cat fdisk-out ida0

Disk /dev/ida/c0d0: 1 heads, 16736160 sectors, 1 cylinders
Units = cylinders of 16736160 * 512 bytes

         Device Boot    Start       End    Blocks   Id  System
/dev/ida/c0d0p1   *         1         1     20384   83  Linux
Partition 1 has different physical/logical beginnings (non-Linux?):
     phys=(0, 1, 1) logical=(0, 0, 33)
Partition 1 has different physical/logical endings:
     phys=(4, 254, 32) logical=(0, 0, 40800)
Partition 1 does not end on cylinder boundary:
     phys=(4, 254, 32) should be (4, 0, 16736160)
/dev/ida/c0d0p2             1         1   8347680    5  Extended
Partition 2 has different physical/logical beginnings (non-Linux?):
     phys=(5, 0, 1) logical=(0, 0, 40801)
Partition 2 has different physical/logical endings:
     phys=(1023, 254, 32) logical=(0, 0, 16736160)
Partition 2 does not end on cylinder boundary:
     phys=(1023, 254, 32) should be (1023, 0, 16736160)
/dev/ida/c0d0p5             1         1   8278304   83  Linux
/dev/ida/c0d0p6             1         1     69344   82  Linux swap

ida0:  Compaq Integrated Array Controller
       Board ID: 0x40400e11
       Firmware Revision: 1.40
       Controller Sig: 0xa0233302
       Memory Address: 0xc8824000
       I/O Port: 0x2000
       IRQ: 5
       Logical drives: 1
       Physical drives: 3

       Current Q depth: 0
       Max Q depth since init: 111

Logical Drive Info:
ida/c0d0: blksz=512 nr_blks=16736160
nr_allocs = 36175
nr_frees = 36175



Comment 4 Matt Wilson 2001-09-07 20:59:24 UTC
luckily we use the device length for doing the partitioning - I don't know how
the cyl constraint solver is getting a solution for this, though...


Comment 5 Jeremy Katz 2001-09-26 19:37:28 UTC
*** Bug 54048 has been marked as a duplicate of this bug. ***

Comment 6 Arjan van de Ven 2003-06-07 19:09:13 UTC
current driver ought to have this fixed


Note You need to log in before you can comment on or make changes to this bug.