Bug 533967 - Cannot use official eclipse downloaded from www.eclipse.org under fedora 12
Cannot use official eclipse downloaded from www.eclipse.org under fedora 12
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 16:58 EST by Fabio Canepa
Modified: 2009-11-10 01:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 01:26:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 287307 None None None Never

  None (edit)
Description Fabio Canepa 2009-11-09 16:58:14 EST
Description of problem:
I've downloaded and installed the official eclipse 3.5.1 for jee developer from www.eclipse.org (I know I can also use the fedora package but I'd would like to use the official eclipse version).
I can start eclipse but whenever I run a wizard to create something, for example when I'm trying to create a new Java project, when I click on the "next" button I cannot go on the next page of wizard.

Version-Release number of selected component (if applicable):
eclipse 3.5.1
kernel 2.6.31.5-127.fc12.x86_64
xorg-x11-server 1.7.1-7.fc12

How reproducible:
always

Steps to Reproduce:
1. Download and install eclipse 3.5.1 for jee developer for linux x86_64 from www.eclipse.org
2.Run eclipse
3.Menu File -> New -> Other... -> Java Project
4 Press Next
  
Actual results:
The wizard don't steps forward on the next page

Expected results:
The wizard goes on the next page where I can enter the name of the Java project...

Additional info:
The problem is presents in every wizard (for example the wizard to create a new Java class)
The problem is also presents with other swt based java application (for examples Apache Directory Studio version 1.5.0)
The problem is presents if I run the java application with openjdk and also with sun-jvm 1.6.0_16
The problem is not present with the eclipse version packaged by fedora. (yum install eclipse-jdt.x86_64)
Comment 1 Andrew Overholt 2009-11-09 17:22:25 EST
There are quite a few bugs filed at bugs.eclipse.org about this.  There were changes made in GTK that cause issues with SWT.  Please try searching bugs.eclipse.org for things like "[GTK2.18]" or "Ubuntu 9.10".

Try running your eclipse.org download like this:

GDK_NATIVE_WINDOWS=true ./eclipse

In any case, this isn't a bug in the Eclipse package in Fedora.  Please either close as UPSTREAM or move to the gtk2 component.
Comment 2 Fabio Canepa 2009-11-10 01:26:41 EST
Thanx Andrew.
I've closed the bug as UPSTREAM and added the reference to eclipse bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=287307

As you suggested in order to use eclipse 3.5.1 under f12 I've created the following script (eclipse.sh)

#!/bin/sh
export GDK_NATIVE_WINDOWS=1
/opt/eclipse-galileo/eclipse

Note You need to log in before you can comment on or make changes to this bug.