Bug 534082 - [abrt] crash detected in glx-utils-7.6-0.13.fc12
[abrt] crash detected in glx-utils-7.6-0.13.fc12
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:8ad77d3fa96d78028beae7390f9...
: Triaged
: 554225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-10 09:24 EST by chedi toueiti
Modified: 2010-04-27 03:36 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 03:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.58 KB, text/plain)
2009-11-10 09:24 EST, chedi toueiti
no flags Details
SELiux error from setroubleshoot (28 bytes, text/plain)
2010-03-01 03:45 EST, Mr. Meval
no flags Details

  None (edit)
Description chedi toueiti 2009-11-10 09:24:32 EST
abrt detected a crash.

Attached file: backtrace
cmdline: glxinfo
component: mesa
executable: /usr/bin/glxinfo
kernel: 2.6.31.5-122.fc12.x86_64
package: glx-utils-7.6-0.13.fc12
rating: 0
reason: Process was terminated by signal 11
Comment 1 chedi toueiti 2009-11-10 09:24:35 EST
Created attachment 368401 [details]
File: backtrace
Comment 2 Adam Jackson 2009-11-18 15:14:09 EST
What hardware is this with?  Can you attach the X log please?
Comment 3 chedi toueiti 2009-11-19 03:16:59 EST
05:00.0 VGA compatible controller: nVidia Corporation GeForce 8400 GS (rev a1)

the problem was related to SeLinux

[chedi@localhost Desktop]$ glxinfo 
glxinfo: error while loading shared libraries: libGL.so.1: cannot enable executable stack as shared object requires: Permission denied

dmesg output:

type=1400 audit(1258615704.222:22972): avc:  denied  { execstack } for  pid=2706 comm="glxinfo" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process

and the issue is simply resolved by turning off the SElinux, I submited another bug report about the issue to the xorg-x11-nvidia team and they responded that they had this issue and they thought it was adressed by the SELinux team.
Comment 4 Aaron Seibert 2009-11-19 07:44:55 EST
I resolved this issue by simply removing all of the xorg-nvidia drivers, and compiling the driver from the NVIDIA installer.  No longer have the framebuffer support during bootup, but everything works fine when X starts.
Comment 5 Chris Campbell 2010-01-10 23:29:22 EST
*** Bug 554225 has been marked as a duplicate of this bug. ***
Comment 6 Mr. Meval 2010-03-01 03:45:49 EST
Created attachment 396983 [details]
SELiux error from setroubleshoot
Comment 7 Mr. Meval 2010-03-01 03:48:19 EST
Attached a link for this.

SELinux has had the boolean for execmem set to active. Look at the attached output of setroubleshoot and setroubleshootd. You will find a fix. 

The program should be rewritten to conform to safe coding practices.

This is detailed here http://people.redhat.com/drepper/selinux-mem.html

Note You need to log in before you can comment on or make changes to this bug.