Bug 534160 - gnome-do crashes when invoking the preferences dialog
Summary: gnome-do crashes when invoking the preferences dialog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-do
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Sindre Pedersen Bjørdal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-10 18:50 UTC by Drew DeNardo
Modified: 2009-12-09 03:55 UTC (History)
6 users (show)

Fixed In Version: 0.8.2-5.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-07 07:29:15 UTC
Type: ---


Attachments (Terms of Use)

Description Drew DeNardo 2009-11-10 18:50:56 UTC
Description of problem:
After installing the app it didn't launch with the 'Docky' interface (I assume the package reverts to a 'default' configuration). I launched gnome-do with the <Super>+<Space> key combination, and then click on the triangle on the top-right corner to drop down the menu. When I click on "preferences", the application terminates and I get the following dump:

Marshaling activate signal                                                                                                   
Exception in Gtk# callback delegate                                                                                          
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.                               
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> GLib.MissingIntPtrCtorException: GLib.Object subclass Do.Interface.ClassicWindow must provide a protected or public IntPtr ctor to support wrapping of native object handles.
  at GLib.ObjectManager.CreateObject (IntPtr raw) [0x00000]
  at GLib.Object.GetObject (IntPtr o, Boolean owned_ref) [0x00000]
  at GLib.Object.GetObject (IntPtr o) [0x00000]
  at Gtk.Grab.get_Current () [0x00000]
  at Do.Core.Controller.ShowPreferences () [0x00000]
  at Do.Universe.PreferencesItem.Run () [0x00000]
  at Do.UI.MainMenu+<MenuItemFromRunnableItem>c__AnonStorey12.<>m__2A (System.Object sender, System.EventArgs e) [0x00000]
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000]
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000]
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000]
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000]
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000]
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000]
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000]
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000]
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000]
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Do.Do.Main(System.String[] args)


Note: I am not sure if the 1st line included ('Marshalling ...") was present prior to clicking on the 'preferences' menu option or not.

Version-Release number of selected component (if applicable):

gnome-do-0.8.2-4.fc12.x86_64

How reproducible:

I was able to reproduce this on 3 out of 3 tries.


Steps to Reproduce:
1. With gnome-do-0.8.2-3.fc12.x86_64.rpm installed, running KDE, and with gnome-do configured to run the "Docky" interface ...
2. Update to gnome-do-0.8.2-4.fc12.x86_64 using yum.
3. Start gnome-do (I used the command-line to do this so that I could see any debug/error output)
4. Invoke gnome-do with the <Super>+<Space> key combination
5. Click on the triangle on the top-right corner to drop down the menu
6. Select 'preferences' from the menu using the mouse
  
Actual results:

Application terminates


Expected results:

The preferences panel displays

Additional info:

Comment 1 Juan Manuel Rodriguez 2009-11-10 19:01:10 UTC
Docky will be removed in future versions of gnome-do due to patent violations (US Patent 7434177).

Comment 2 Mariusz Smykuła 2009-11-18 10:05:29 UTC
What with cairo-dock? Cairo is better because not using mono?

Comment 3 Mariusz Smykuła 2009-11-18 10:07:19 UTC
This package should be moved (not removed) to rpmfusion. Simply cooperation make things easiers for users!

Comment 4 Juan Manuel Rodriguez 2009-11-18 14:54:05 UTC
I agree, Mariusz. I'll start the procedures to get this into RPMFusion.

Comment 5 Mariusz Smykuła 2009-11-18 16:15:25 UTC
Thanks, I filled wishlist for Docky in RPMFusion. 

Please think also about gnome-do-docklets, this was missing in Fedora repos but is needed for users :)

Comment 6 Juan Manuel Rodriguez 2009-11-18 16:23:22 UTC
gnome-do-docklets is coming, I was going to submit it to Fedora, but I guess it'll go to RPMFusion instead. 

I'll talk to upstream before doing anything, since abadger convinced me to leave gnome-do (Crippled), and gnome-do-plugins in Fedora, then use gnome-do-docklets to install the docklets and "docky" too.

Comment 7 Fedora Update System 2009-11-18 18:47:54 UTC
gnome-do-0.8.2-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnome-do-0.8.2-5.fc11

Comment 8 Fedora Update System 2009-11-18 18:48:47 UTC
gnome-do-0.8.2-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnome-do-0.8.2-5.fc12

Comment 9 Adam Williamson 2009-11-18 23:36:13 UTC
mariusz, as the whole point of RPM Fusion is to be completely separate from and not affiliated with Fedora, there is of course no official process for 'co-operation' between the two. If a package is 'moved' from Fedora to RPM Fusion, as far as Fedora is concerned, that's exactly the same as it being removed.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 10 Mariusz Smykuła 2009-11-19 08:18:04 UTC
ok, thanks for clarification

Comment 11 Fedora Update System 2009-11-20 05:27:24 UTC
gnome-do-0.8.2-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-do'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11802

Comment 12 Fedora Update System 2009-11-20 05:32:58 UTC
gnome-do-0.8.2-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-do'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-11844

Comment 13 Mariusz Smykuła 2009-11-20 06:10:35 UTC
nice, but still incomplete (without docklets), better is to compile from source.

Comment 14 Juan Manuel Rodriguez 2009-11-20 15:23:08 UTC
I don't think gnome-do-docklets will ever be in the Fedora repos. 

The gnome-do Developers are splitting gnome-do and Docky into their own packages, and gnome-do will stop shipping the 'docky' theme. 

gnome-do-docklets will become docky-docklets, if they don't come with docky by default. 

And due to that possible patent violation, I won't submit Docky to these repos. Noone wants a crippled version of a program.

Comment 15 Fedora Update System 2009-12-07 07:29:10 UTC
gnome-do-0.8.2-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2009-12-07 07:29:30 UTC
gnome-do-0.8.2-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Jud Craft 2009-12-09 03:55:27 UTC
I think #2 brings up an interesting point.

Cairo-dock, AWN-dock, and Do-Docky are all clones of the same basic functionality.  Gnome-Do simply has more public visibility and more likely to receive a patent offense.

Does Fedora Legal have a policy for applications that implement a similar functionality, where one app of the set is cited for patent infringement?


Note You need to log in before you can comment on or make changes to this bug.