Bug 53418 - USB devices inaccessible
USB devices inaccessible
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-08 10:42 EDT by bastiaan
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-03 16:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contents of /proc/interrupts (469 bytes, text/plain)
2001-09-08 11:22 EDT, bastiaan
no flags Details

  None (edit)
Description bastiaan 2001-09-08 10:42:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
The kernel detects the USB UHCI Root Hubs on my AOpen AK73 Pro(A) MoBo ,
but does not recognize the attached USB Intellimouse and Wacom Graphire
tablet devices.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Clean Install Roswell 2
2.cat /proc/bus/usb/devices
3.
	

Actual Results:  /proc/bus/usb/devices shows:

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=d800
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=d400
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms


Expected Results:  I would expect to see entries for the mouse and tablet.

Additional info:

lspci shows:
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South]
(rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. AC97 Audio
Controller (rev 50)
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
01:00.0 VGA compatible controller: nVidia Corporation Riva TnT2 [NV5] (rev 15)

Also, disconnecting and reconnecting a device to the USB bus generates the
following entries in /var/log/messages:

Sep  8 16:22:49 overlord kernel: hub.c: USB new device connect on bus1/1,
assigned device number 8
Sep  8 16:22:53 overlord kernel: usb_control/bulk_msg: timeout
Sep  8 16:22:53 overlord kernel: usb.c: USB device not accepting new
address=8 (error=-110)
Sep  8 16:22:54 overlord kernel: hub.c: USB new device connect on bus1/1,
assigned device number 9
Sep  8 16:22:58 overlord kernel: usb_control/bulk_msg: timeout
Sep  8 16:22:58 overlord kernel: usb.c: USB device not accepting new
address=9 (error=-110)
Comment 1 Pete Zaitcev 2001-09-08 11:03:11 EDT
Please attach the contents of "/proc/interrupts".
Comment 2 bastiaan 2001-09-08 11:22:27 EDT
Created attachment 31334 [details]
contents of /proc/interrupts
Comment 3 Pete Zaitcev 2001-09-08 11:40:10 EDT
I think it is the Tyan Tyger redux - broken BIOS for KT1333.
USB is not getting interrupts.

Does the BIOS print anything interesting on the screen
when it starts, about the IRQ ##? Also, try to wiggle
any settings in it.

Comment 4 bastiaan 2001-09-08 12:19:16 EDT
Well, I tried to 'wiggle' some settings, but the Award BIOS of the motherboard
hasn't many USB related ones:
* disable/enable USB.
* Plug&Play OS.
* disable/enable IRQ for USB.

I tried all settings for the last two options, but none did improve the situation.
The BIOS doesn't print any interesting info at boot time.

Any suggestions? Both mouse and table DO work with Win2000 professional....



Comment 5 bastiaan 2002-05-22 11:37:11 EDT
I've changed the product field to RH Linux, since the problem is still there in
RH7.2 and RH7.3.
Could you please explain what you mean with 'Tyan Tiger redux', or where to find
more information on the subject? Thanks!
Comment 6 Arjan van de Ven 2002-05-28 09:52:17 EDT
does W2K tell you which irq USB uses ?
Comment 7 bastiaan 2002-06-03 16:55:55 EDT
Hi, sorry for the slow reply: had already wiped the original Win2000 install. A
fresh Win2000 Professional gives:

VIA USB UHCI 1: IRQ 11, I/O C400-C41F, PCI bus 0, dev 7, func 2
VIA USB UHCI 2: IRQ 11, I/O C800-C81F, PCI bus 0, dev 7, func 3

If you want more data, please let me know. Thanks.



Comment 8 bastiaan 2002-07-24 17:18:03 EDT
Finally I got USB working: a BIOS upgrade fixed the problem. Relevant info:

Motherboard: AOpen AK73 Pro(A).
Broken BIOS versions: at least 1.13 (and earlier ?).   
Fixed BIOS version: 1.18 (maybe others > 1.13 are OK too)

Tested on RH 7.3 with kernel-2.4.18-3.

The corrected BIOS is available at:
http://www.aopen.com/tech/download/mbbios/ak73pro.htm 

Thanks, BB

Note You need to log in before you can comment on or make changes to this bug.