Bug 53423 - IDE errors reading from CD [Installer crashes: error while loading shared libraries]
IDE errors reading from CD [Installer crashes: error while loading shared lib...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-08 11:29 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 13:14:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-08 11:29:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.0)

Description of problem:
After detecting the SCSI controllers, I get the message:
Running anaconda - please wait...
/usr/bin/python: error while loading shared libraries: libdl.so.2: cannot 
load shared object file: Input/Output error.
install exited abnormally.

And then it does a shutdown and prompts for a reboot.

Hardware:
Dell PowerEdge 1550 - 512MB RAM, RAID5 SCSI Controller, 3x36GB SCSI disks 
in RAID5 array, PIII 933MHz.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from RED Hat 7.1 installation CD.
2.
3.
	

Actual Results:  Running anaconda - please wait...
/usr/bin/python: error while loading shared libraries: libdl.so.2: cannot 
load shared object file: Input/Output error.
install exited abnormally.

Expected Results:  Should have got graphical installtion window.

Additional info:
Comment 1 Matt Wilson 2001-09-08 13:26:48 EDT
try booting with "linux ide=nodma" at the boot: prompt
Comment 2 Need Real Name 2001-09-10 06:14:55 EDT
I tried linux ide=nodma.
It did exactly the same again. The output from the ALT-F4 screen shows the 
following errors (last lines of the log):

<7>ISO 9660 Extensions: RRIP_1991A
<4>Unable to indentify CD-ROM format.
<4>hda: command error: status=0x51 { DriveReady SeekComplete Error }
<4>hda: command error: error=0x54
<4>end_request: I/O error, dev 03:00 (hda), sector 1045976
<6>raid0 personality registered as nr 2 
<6>raid1 personality registered as nr 3
<6>raid5: measuring checksumming speed
<4>   8regs     :  1536.000 MB/sec
<4>   32regs    :   857.600 MB/sec
<4>   pII_mmx   :  2098.800 MB/sec
<4>   p5_mmx    :  2214.400 MB/sec
<4>raid5: using function: p5_mmx (2214.400 MB/sec)
<6>raid5 personality registered as nr 4
Comment 3 Matt Wilson 2001-09-12 12:14:31 EDT
These errors point to bad media or drive or controller or cable.

<4>hda: command error: status=0x51 { DriveReady SeekComplete Error }
<4>hda: command error: error=0x54
<4>end_request: I/O error, dev 03:00 (hda), sector 1045976

Comment 4 Need Real Name 2001-09-12 12:30:01 EDT
The Red Hat 7.0 CD set works ok as does the 'Roswell' beta version.
I have also tried the 7.1 media in another machine (different spec) and that 
works fine.

If I was to use the Roswell version, how far from full release is it? IE is it 
likely to be a few package updates which I could apply at the time of full 
release or are there likely to be major differences? The server will be used as 
a central web/mail server.
Comment 5 Alan Cox 2003-06-07 13:14:52 EDT
Closing: this bug relates to what seems to be a media error one drive hits not
others, and to an install kernel with ide/cd code that is no longer related to
the code we ship in RH 9.

Note You need to log in before you can comment on or make changes to this bug.