Bug 53429 - Adaptec 2100s Raid controller
Adaptec 2100s Raid controller
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-09-08 14:27 EDT by ken
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-12 12:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description ken 2001-09-08 14:27:03 EDT
Just purchased RH Linux 7.1 Server:

The is no native driver support for this controller.  Downloaded drivers 
from Adaptec and followed installation instructions.  Everything is fine 
until I get to the Installation type.  I have tried all of them except 
upgrade.  Mainly I was trying to perform a custom installation.  The 
following error occured:

An error has occurred - No valid devices were found on which to create new 
file systems. Please check your hardware for the cause of this problem.


I followed the step specified by adaptec:
1. Rawrite the image to a floppy
2. Booted cd
3. At welcome I typed expert
4. Prompted for driver disk
5. It saw the correct controller
6. It started anaconda
7. Asked for mouse type
8. Proceeded to welcome in setup
9. Clicked next
10. Asked what type of installation
11. Chose custom.
12. Failed with above error

I am new to linux please help...
Comment 1 Matt Wilson 2001-09-10 09:43:24 EDT
which driver is this card using from Adaptec?
Comment 2 ken 2001-09-11 02:23:51 EDT
Redhat Linux 7.0 Boot-time loadable driver version 2.2-1
Comment 3 Matt Wilson 2001-09-12 12:15:04 EDT
you're using a 7.0 driver on 7.1?
Comment 4 Brent Fox 2001-09-24 12:13:30 EDT
Closing due to inactivity.  Please reopen if you have more information.
Comment 5 Need Real Name 2001-10-17 00:31:33 EDT
See new comment added to Bug 36257.  I just got the new 2100S driver for RH Linux 7.1 from Adaptec.  It looks like something about 
loading a device driver at the beginning of the install causes the installer to stop seeing the CD-ROM device, which prevents 
continuing with the install.  While I haven't tried it yet, a possible workaround is to create a boot floppy and boot from it, load the driver, 
then launch the installer.  Comments anyone?

bob mcgrath  (206) 226-6717

Note You need to log in before you can comment on or make changes to this bug.