Bug 534326 - (RHQ-1133) fix performance of ResourceError callback from agent to server - 1_1_2_GA_CP
fix performance of ResourceError callback from agent to server - 1_1_2_GA_CP
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
1.1.2
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Corey Welton
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-1131
  Show dependency treegraph
 
Reported: 2008-11-19 12:02 EST by Joseph Marques
Modified: 2009-11-10 16:22 EST (History)
0 users

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2008-11-19 12:02:00 EST

    
Comment 1 Joseph Marques 2008-11-19 12:15:19 EST
rev2033 - fix so that the only piece of data sent up in the ResourceError object is the resourceId, not the entire agent-side resource hierarchy; 
Comment 2 Joseph Marques 2008-11-19 12:16:15 EST
no QA is needed on this.  this one-line fix can be verified by inspection.
Comment 3 Jay Shaughnessy 2008-11-20 16:09:55 EST
There seems to be an additional issue. The new lightweight resource fails serialization and the setResourceError message fails at send-time.  Th externalization of Resource needs to be more tolerant. Note that this means making assumptions about the data provided by Resource will be dangerous when dealing with an deserialized Resource object.
Comment 4 Jay Shaughnessy 2008-11-20 17:04:46 EST
r2052 fixed in Trunk, moving to CP
Comment 5 Jay Shaughnessy 2008-11-20 17:20:59 EST
Checked into trunk and 112 GA CP.



Comment 6 Corey Welton 2008-12-18 15:09:30 EST
QA closing, code-level change.
Comment 7 Red Hat Bugzilla 2009-11-10 15:24:42 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1133

Note You need to log in before you can comment on or make changes to this bug.