Bug 53446 - Mount freezes in a state = D. And no more mounts or unmount are possible.
Mount freezes in a state = D. And no more mounts or unmount are possible.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-09 00:11 EDT by Carlos Miguel Sousa Almeida
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 13:15:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Miguel Sousa Almeida 2001-09-09 00:11:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816

Description of problem:
I tried to mount a /dev/sda1 (digital camera USB), and the process stop in
state D, after that i can't mount or unmount a thing and no one can kill
them, even in reboot i have to do a power reset.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Add aline in fstab to mount like "/dev/sda1	/mnt/Fuji	vfat	 exec,dev,suid,rw,noauto,umask=0,users 0 0"
2. Then try to mount /mnt/Fuji
3. note: Fuji is a USB digital camera. It works sometimes.



Actual Results:  The /bin/mount process is freeze and no one can kill it,
even by a kill -9 or killall.
After that i can't mount or unmount anything.
A restar must be by power reset. It stop in "stopping automount"

Expected Results:  Mounted the digital camera.

Additional info:

I have a Athlon, 1Ghz, 256Mram, one IDE disc, a DVD ROM, kernel 2.4.2.
I'm affraid to lose information, doing the power reset.
Comment 1 Bernhard Rosenkraenzer 2001-09-09 16:32:27 EDT
It would appear that the kernel system call is hanging.

Comment 2 Alan Cox 2003-06-07 13:15:47 EDT
USb storage has had a major rework since 2.4.2. Multiple hang bugs have been fixed.

Note You need to log in before you can comment on or make changes to this bug.