Bug 534493 - (RHQ-1285) improve load time for viewing the details of a group plugin configuration update
improve load time for viewing the details of a group plugin configuration update
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On: RHQ-1559
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 17:26 EST by Joseph Marques
Modified: 2014-11-09 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2008-12-18 17:26:00 EST
the resource people will see slowly today is because we're loading potentially lots of big configuration objects across the wire and into memory, but they aren't even used.  the object in question is PluginConfigurationUpdateResourceComposite which maps to the PluginConfigurationUpdate.QUERY_FIND_COMPOSITE_BY_PARENT_UPDATE_ID query.  if we return just the update object with the nested configuration detached, page load times should improve by 100-1000x times (just as they did when a similar performance fix was added to operation histories).
Comment 1 Charles Crouch 2008-12-18 18:11:44 EST
See case 250079
Comment 2 Joseph Marques 2008-12-18 18:23:50 EST
rev2471 - reduce the payload across the wire by removing the Configuration entity object from the result set entries; 

charles, how does 15ms for the latest page-load sound?  ; )
Comment 3 Jeff Weiss 2009-02-12 15:10:47 EST
I will reject this one so I know to retest it when dependent bugs are fixed.
Comment 4 Jeff Weiss 2009-02-12 15:11:22 EST
Blocked by dependent bug.  please re-resolve with the same rev# as the dependent bug, when it's fixed.
Comment 5 Joseph Marques 2009-02-12 17:32:48 EST
re-resolve @ 3038 as QA asked.
Comment 6 Jeff Weiss 2009-03-31 11:01:40 EDT
Both "View Group Update" and "View Member Updates" details page load quickly for a group of 100 resources (JMS Topic).  rev3509, linux/oracle.
Comment 7 Red Hat Bugzilla 2009-11-10 15:29:45 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1285
This bug relates to RHQ-1260

Note You need to log in before you can comment on or make changes to this bug.