This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 534549 - (RHQ-1335) Events subsystem needs to support throttling when adding events
Events subsystem needs to support throttling when adding events
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Performance (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 19:45 EST by Charles Crouch
Modified: 2015-02-01 18:24 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-01-08 19:45:00 EST
Right now there doesn't appear to any upper limit on the rate at which we can add rows to the RHQ_EVENT table. Unlike metric data for which collection intervals and number of resource in the inventory can be used to influence the rate at which that data comes in. For example, having multiple agents monitoring log files for which log entries are being written every millisecond ended up producing >17gb worth of data in the RHQ_EVENT table. Inserting this amount of data puts an excessive strain on the DB and most likely also makes subsequently purging the data impossible. 

The solution to this issue would be to ensure that "event floods" are not allowed to crush the database and that our event purge algorithm can support the rate at which event rows are added and also the total table size its possible to end up with.
Comment 1 John Mazzitelli 2009-01-08 20:16:21 EST
this is a duplicate of RHQ-1122
Comment 2 Red Hat Bugzilla 2009-11-10 15:30:49 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1335
This bug duplicates RHQ-1122

Note You need to log in before you can comment on or make changes to this bug.